summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-10-01 11:46:48 +0800
committerJason Zaman <perfinion@gentoo.org>2016-10-03 15:02:41 +0800
commitd82cdfbb17e70b1a258dad133d80451e7f8f571a (patch)
tree60bcc30c7d12135539f14e9f94405eca5e16d938 /sys-apps
parentsys-apps/policycoreutils: bump to 2.6-rc1 (diff)
downloadgentoo-d82cdfbb17e70b1a258dad133d80451e7f8f571a.tar.gz
gentoo-d82cdfbb17e70b1a258dad133d80451e7f8f571a.tar.bz2
gentoo-d82cdfbb17e70b1a258dad133d80451e7f8f571a.zip
sys-apps/secilc: bump to 2.6-rc1
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/secilc/Manifest1
-rw-r--r--sys-apps/secilc/secilc-2.6_rc1.ebuild39
-rw-r--r--sys-apps/secilc/secilc-9999.ebuild10
3 files changed, 42 insertions, 8 deletions
diff --git a/sys-apps/secilc/Manifest b/sys-apps/secilc/Manifest
index 7fea2354f28f..8ff1a201f277 100644
--- a/sys-apps/secilc/Manifest
+++ b/sys-apps/secilc/Manifest
@@ -1 +1,2 @@
DIST secilc-2.5.tar.gz 174642 SHA256 4303d911c06ee5c207e00f778ca786c1a6efa2554a562f5d014dbc0d2f4cc4a4 SHA512 7f7b6fb72bee7018f7a591e6a7d8f58a81ed0e1ec914e0792ccd57a550756a5e21c6359e35ad2fe29225a0bd352637d01288721de3b95a9a175bb3ab052620b9 WHIRLPOOL e674039433041f527a1346ad64887254fa4d7f37f3125b08edcf1e16e23f1d40e1b1151cf6e10d4875d849c43a6b39af0069185303f23b5f331b39c1433deb0e
+DIST secilc-2.6-rc1.tar.gz 174555 SHA256 201b30905e84704d0083f8bc20322c2e2f44b0b047234364fb654a5525c0ec5e SHA512 4e2608bbe3b970bed9838dcf9518e06cd049cd3bb977e83a6e1072390867edc519bac12b02dd8130cf3af5c3a2b1571910d6033c5ccb58d479e6b3b853d105c2 WHIRLPOOL 8390e497e5b3c2bcda72cc64342dc29b44318b4df465b6e128126f716f8db060112778a9cba36a5341ac0189acb44630f5c97b2e876047d882d060d4d276b7f4
diff --git a/sys-apps/secilc/secilc-2.6_rc1.ebuild b/sys-apps/secilc/secilc-2.6_rc1.ebuild
new file mode 100644
index 000000000000..2d316f8aeb42
--- /dev/null
+++ b/sys-apps/secilc/secilc-2.6_rc1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+MY_P="${P//_/-}"
+MY_RELEASEDATE="20160930"
+
+SEPOL_VER="${PV}"
+
+DESCRIPTION="SELinux Common Intermediate Language (CIL) Compiler"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/xmlto
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+RDEPEND="
+ >=sys-libs/libsepol-${SEPOL_VER}
+ "
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
diff --git a/sys-apps/secilc/secilc-9999.ebuild b/sys-apps/secilc/secilc-9999.ebuild
index 9b5d6dac018d..2d316f8aeb42 100644
--- a/sys-apps/secilc/secilc-9999.ebuild
+++ b/sys-apps/secilc/secilc-9999.ebuild
@@ -2,12 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-
-inherit toolchain-funcs eutils
+EAPI="6"
MY_P="${P//_/-}"
-MY_RELEASEDATE="20160223"
+MY_RELEASEDATE="20160930"
SEPOL_VER="${PV}"
@@ -39,7 +37,3 @@ RDEPEND="
# tests are not meant to be run outside of the
# full SELinux userland repo
RESTRICT="test"
-
-src_prepare() {
- epatch_user
-}