summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-28 08:28:25 +0100
committerSam James <sam@gentoo.org>2023-06-28 08:36:59 +0100
commitd912ee0782da559450799c33158c0c6975101e4b (patch)
tree776fee8baeb41fc6e600a3a91278d123ddbe0beb /sys-apps
parentnet-proxy/lyrebird: add missing selinux policy dep (diff)
downloadgentoo-d912ee0782da559450799c33158c0c6975101e4b.tar.gz
gentoo-d912ee0782da559450799c33158c0c6975101e4b.tar.bz2
gentoo-d912ee0782da559450799c33158c0c6975101e4b.zip
sys-apps/logwatch: add missing selinux policy dep
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/logwatch/logwatch-7.8-r1.ebuild8
-rw-r--r--sys-apps/logwatch/logwatch-9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-apps/logwatch/logwatch-7.8-r1.ebuild b/sys-apps/logwatch/logwatch-7.8-r1.ebuild
index a7ef017b044c..22edd4652a28 100644
--- a/sys-apps/logwatch/logwatch-7.8-r1.ebuild
+++ b/sys-apps/logwatch/logwatch-7.8-r1.ebuild
@@ -5,6 +5,9 @@ EAPI=8
inherit tmpfiles
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
inherit git-r3
@@ -13,11 +16,9 @@ else
KEYWORDS="~alpha amd64 arm arm64 hppa ppc ppc64 sparc x86"
fi
-DESCRIPTION="Analyzes and Reports on system logs"
-HOMEPAGE="https://sourceforge.net/projects/logwatch/"
-
LICENSE="MIT"
SLOT="0"
+IUSE="selinux"
RDEPEND="
dev-lang/perl
@@ -30,6 +31,7 @@ RDEPEND="
virtual/cron
virtual/mta
virtual/mailx
+ selinux? ( sec-policy/selinux-logwatch )
"
src_install() {
diff --git a/sys-apps/logwatch/logwatch-9999.ebuild b/sys-apps/logwatch/logwatch-9999.ebuild
index 5f4d3a5769c8..7f77c326c65c 100644
--- a/sys-apps/logwatch/logwatch-9999.ebuild
+++ b/sys-apps/logwatch/logwatch-9999.ebuild
@@ -5,6 +5,9 @@ EAPI=8
inherit tmpfiles
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="https://sourceforge.net/projects/logwatch/"
+
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.code.sf.net/p/logwatch/git ${PN}"
inherit git-r3
@@ -13,11 +16,9 @@ else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi
-DESCRIPTION="Analyzes and Reports on system logs"
-HOMEPAGE="https://sourceforge.net/projects/logwatch/"
-
LICENSE="MIT"
SLOT="0"
+IUSE="selinux"
RDEPEND="
dev-lang/perl
@@ -30,6 +31,7 @@ RDEPEND="
virtual/cron
virtual/mta
virtual/mailx
+ selinux? ( sec-policy/selinux-logwatch )
"
src_install() {