summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-07-30 13:02:29 +0200
committerPacho Ramos <pacho@gentoo.org>2023-07-30 13:02:29 +0200
commite257a326470635025cb862cd6931bf06257e64fa (patch)
tree854f2d1e0695b2a5ba94e1d247285de4a3b7e727 /sys-apps
parentsys-libs/binutils-libs: 2.40 patchset 6 bump (diff)
downloadgentoo-e257a326470635025cb862cd6931bf06257e64fa.tar.gz
gentoo-e257a326470635025cb862cd6931bf06257e64fa.tar.bz2
gentoo-e257a326470635025cb862cd6931bf06257e64fa.zip
sys-apps/xdg-desktop-portal-gnome: add 44.2
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gnome/Manifest b/sys-apps/xdg-desktop-portal-gnome/Manifest
index 1e3490aacf1b..7efe5fa2891a 100644
--- a/sys-apps/xdg-desktop-portal-gnome/Manifest
+++ b/sys-apps/xdg-desktop-portal-gnome/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-gnome-44.1.tar.xz 127504 BLAKE2B ceae17bc5aea4c3c6a8420af56439698cbb57fbb35f7ba671a8469778aa87843314db6f021c92a8c69859d5943cf4d568069b94050fa89e27f08a0c0bd398366 SHA512 58e165b06a7b8dd8dd87cd2874db87e1e6e608e9752334f6c1ae341acd28857dca2d02ef1659b174dd4041897e898455ee99cde1cdf4b28f9e3a88d4dba73989
+DIST xdg-desktop-portal-gnome-44.2.tar.xz 127484 BLAKE2B a6984cc2403f9edcaf638a241559bc6aa75ab9ce96fb482c50a2bb26803100e4ce2b8cedff1e8032a62369f5b73bd6679566a58a4817dc2dbbbf4d0c13140351 SHA512 3cf70a8523e72b9d523d3ada38b48f654259b13b91b6a20d45c68c0a353dc78b6fdd599dfd6d9385ef67c4f71728df976dc38b02c8668a5d698f6f6d3728dee7
DIST xdg-desktop-portal-gnome-45.alpha.tar.xz 127556 BLAKE2B f655b2c2cf2d1c64c4ab8018bc7999ae570ec5d1c007b9ac088b3932ec36b9101fff35e455478a14c0759d48499dbba0054544a3fec2d0d99331aa3c65765da5 SHA512 6003604cc5a6c3cf78c4ac4a312d530918a7b9c651bd28ea1375b21ce3d9e4b2349678107de716b71cb10aef19eb5fb9a57922c8cf2bcf305afb99d5e74c775b
diff --git a/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.2.ebuild b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.2.ebuild
new file mode 100644
index 000000000000..d75beb04c2ad
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gnome/xdg-desktop-portal-gnome-44.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson systemd xdg
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+# Newer-than-strictly-required xdg-desktop-portal dep for hang/slowness fixes
+# https://gitlab.gnome.org/GNOME/xdg-desktop-portal-gnome/-/issues/74
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:4=
+ gui-libs/libadwaita:1
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.16.0-r1
+ >=sys-apps/xdg-desktop-portal-gtk-1.14.0
+ gui-libs/gtk:4[wayland?,X?]
+ X? ( x11-libs/libX11 )
+ wayland? ( dev-libs/wayland )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ wayland? ( dev-util/wayland-scanner )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ meson_src_configure
+}