summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-02-11 17:00:36 -0500
committerMike Gilbert <floppym@gentoo.org>2023-02-11 17:13:14 -0500
commite3b100621b371849f79a62ba82c9fe2c4ef6b2dd (patch)
treedbf820d7deec870e6933b79976f96af38d27a9f6 /sys-apps
parentgui-libs/libadwaita: Version bump to 1.2.2 (diff)
downloadgentoo-e3b100621b371849f79a62ba82c9fe2c4ef6b2dd.tar.gz
gentoo-e3b100621b371849f79a62ba82c9fe2c4ef6b2dd.tar.bz2
gentoo-e3b100621b371849f79a62ba82c9fe2c4ef6b2dd.zip
sys-apps/util-linux: backport fix for implicit declartion of pidfd_open
Closes: https://bugs.gentoo.org/893966 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/files/util-linux-2.38.1-check-for-sys-pidfd.h.patch52
-rw-r--r--sys-apps/util-linux/util-linux-2.38.1-r2.ebuild (renamed from sys-apps/util-linux/util-linux-2.38.1-r1.ebuild)10
2 files changed, 55 insertions, 7 deletions
diff --git a/sys-apps/util-linux/files/util-linux-2.38.1-check-for-sys-pidfd.h.patch b/sys-apps/util-linux/files/util-linux-2.38.1-check-for-sys-pidfd.h.patch
new file mode 100644
index 000000000000..0a1975fff685
--- /dev/null
+++ b/sys-apps/util-linux/files/util-linux-2.38.1-check-for-sys-pidfd.h.patch
@@ -0,0 +1,52 @@
+https://github.com/util-linux/util-linux/pull/1769
+https://bugs.gentoo.org/893966
+
+From 84732a8849a08d42a9a95dcbee9005116be78eb8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 7 Aug 2022 14:39:19 -0700
+Subject: [PATCH] check for sys/pidfd.h
+
+This header in newer glibc defines the signatures of functions
+pidfd_send_signal() and pidfd_open() and when these functions are
+defined by libc then we need to include the relevant header to get
+the definitions. Clang 15+ has started to error out when function
+signatures are missing.
+
+Fixes errors like
+misc-utils/kill.c:402:6: error: call to undeclared function 'pidfd_send_signal'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
+ if (pidfd_send_signal(pfd, ctl->numsig, &info, 0) < 0)
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ configure.ac | 1 +
+ include/pidfd-utils.h | 4 +++-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 51deeecd4e..daa8f0dca4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -342,6 +342,7 @@ AC_CHECK_HEADERS([ \
+ sys/mkdev.h \
+ sys/mount.h \
+ sys/param.h \
++ sys/pidfd.h \
+ sys/prctl.h \
+ sys/resource.h \
+ sys/sendfile.h \
+diff --git a/include/pidfd-utils.h b/include/pidfd-utils.h
+index eddede9767..d9e33cbc57 100644
+--- a/include/pidfd-utils.h
++++ b/include/pidfd-utils.h
+@@ -4,8 +4,10 @@
+ #ifdef HAVE_SYS_SYSCALL_H
+ # include <sys/syscall.h>
+ # if defined(SYS_pidfd_send_signal) && defined(SYS_pidfd_open)
++# ifdef HAVE_SYS_PIDFD_H
++# include <sys/pidfd.h>
++# endif
+ # include <sys/types.h>
+-
+ # ifndef HAVE_PIDFD_SEND_SIGNAL
+ static inline int pidfd_send_signal(int pidfd, int sig, siginfo_t *info,
+ unsigned int flags)
diff --git a/sys-apps/util-linux/util-linux-2.38.1-r1.ebuild b/sys-apps/util-linux/util-linux-2.38.1-r2.ebuild
index 746b411e2e6e..f49e21c65cae 100644
--- a/sys-apps/util-linux/util-linux-2.38.1-r1.ebuild
+++ b/sys-apps/util-linux/util-linux-2.38.1-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit toolchain-funcs libtool flag-o-matic bash-completion-r1 usr-ldscript \
+inherit toolchain-funcs autotools flag-o-matic bash-completion-r1 usr-ldscript \
pam python-r1 multilib-minimal multiprocessing systemd
MY_PV="${PV/_/-}"
@@ -93,6 +93,7 @@ RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}"/${P}-more-posix-exit-on-eof.patch
+ "${FILESDIR}"/util-linux-2.38.1-check-for-sys-pidfd.h.patch
)
pkg_pretend() {
@@ -153,12 +154,7 @@ src_prepare() {
fi
- if [[ ${PV} == 9999 ]] ; then
- po/update-potfiles
- eautoreconf
- else
- elibtoolize
- fi
+ eautoreconf
}
lfs_fallocate_test() {