summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-06 23:20:45 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-08 22:38:48 +0200
commite918cf72c007c47bf37e222448aad3514891aecd (patch)
tree22bf8025fe8bf184797219775f71af62cde7454c /sys-apps
parentdev-lang/go: stable 1.12.9 on amd64 and x86 (diff)
downloadgentoo-e918cf72c007c47bf37e222448aad3514891aecd.tar.gz
gentoo-e918cf72c007c47bf37e222448aad3514891aecd.tar.bz2
gentoo-e918cf72c007c47bf37e222448aad3514891aecd.zip
sys-apps/smc-sum-driver: use correct kernel for compilation
Pass correct options for compiling against the correct kernel version. Closes: https://bugs.gentoo.org/693528 Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild
new file mode 100644
index 000000000000..d9f03bc988ec
--- /dev/null
+++ b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN//-/_}"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN/smc_/}_V${MY_PV}"
+
+DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RESTRICT="bindist fetch mirror"
+
+S="${WORKDIR}"/${MY_P}/Linux
+
+BUILD_TARGETS="default"
+MODULE_NAMES="sum_bios(misc:${S})"
+
+pkg_nofetch() {
+ elog "Please contact the Supermicro support at support@supermicro.com,"
+ elog "in order to obtain a copy of ${A}"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ default
+
+ # Install new Makefile to respect users CFLAGS and LDFLAGS
+ cp "${FILESDIR}"/makefile Makefile
+}
+
+src_compile() {
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+
+ linux-mod_src_compile
+}