summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-09-18 13:39:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-09-18 13:39:36 +0100
commitfc034c82b286e891d50f2c1e516640ee3107104c (patch)
tree94e0934332fe7a18f324a4d857bb1ed6751daaae /sys-apps
parentsci-astronomy/casacore: Allow for compiling with GCC 6 (diff)
downloadgentoo-fc034c82b286e891d50f2c1e516640ee3107104c.tar.gz
gentoo-fc034c82b286e891d50f2c1e516640ee3107104c.tar.bz2
gentoo-fc034c82b286e891d50f2c1e516640ee3107104c.zip
sys-apps/file: apply missing magic.h fix from bug #586444
The bug #586444 manifested on a cross-compiler case as well when we built native 'file'. Reported-by: n05 on #gentoo-embedded Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.28.ebuild1
-rw-r--r--sys-apps/file/file-9999.ebuild1
2 files changed, 2 insertions, 0 deletions
diff --git a/sys-apps/file/file-5.28.ebuild b/sys-apps/file/file-5.28.ebuild
index fefe087b54f4..e70a726a87fa 100644
--- a/sys-apps/file/file-5.28.ebuild
+++ b/sys-apps/file/file-5.28.ebuild
@@ -87,6 +87,7 @@ multilib_src_compile() {
src_compile() {
if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
+ emake -C "${WORKDIR}"/build/src magic.h #586444
emake -C "${WORKDIR}"/build/src file
PATH="${WORKDIR}/build/src:${PATH}"
fi
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 466e1944b093..b067a3e2afbd 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -85,6 +85,7 @@ multilib_src_compile() {
src_compile() {
if tc-is-cross-compiler && ! ROOT=/ has_version "~${CATEGORY}/${P}" ; then
+ emake -C "${WORKDIR}"/build/src magic.h #586444
emake -C "${WORKDIR}"/build/src file
PATH="${WORKDIR}/build/src:${PATH}"
fi