summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-19 17:39:29 +0100
committerSam James <sam@gentoo.org>2023-08-19 17:39:35 +0100
commitfe07031dfb04ac810a67a77a30e2452eb346cb61 (patch)
tree87f7a681ab07d0be6f2d2265c52b51c559db6315 /sys-apps
parentsys-apps/portage: shift phases to match execution order (diff)
downloadgentoo-fe07031dfb04ac810a67a77a30e2452eb346cb61.tar.gz
gentoo-fe07031dfb04ac810a67a77a30e2452eb346cb61.tar.bz2
gentoo-fe07031dfb04ac810a67a77a30e2452eb346cb61.zip
sys-apps/portage: use xdist, epytest-style formatting
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/portage/portage-3.0.50.ebuild9
-rw-r--r--sys-apps/portage/portage-9999.ebuild9
2 files changed, 14 insertions, 4 deletions
diff --git a/sys-apps/portage/portage-3.0.50.ebuild b/sys-apps/portage/portage-3.0.50.ebuild
index ec4db2e48278..752d29f03855 100644
--- a/sys-apps/portage/portage-3.0.50.ebuild
+++ b/sys-apps/portage/portage-3.0.50.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE='bzip2(+),threads(+)'
TMPFILES_OPTIONAL=1
-inherit meson linux-info python-r1 tmpfiles
+inherit meson linux-info multiprocessing python-r1 tmpfiles
DESCRIPTION="The package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -37,7 +37,10 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools[${PYTHON_USEDEP}]
' python3_12)
- test? ( dev-vcs/git )
+ test? (
+ dev-vcs/git
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
"
DEPEND="
${PYTHON_DEPS}
@@ -153,6 +156,8 @@ src_compile() {
}
src_test() {
+ local -x PYTEST_ADDOPTS="-vv -ra -l -o console_output_style=count -n $(makeopts_jobs) --dist=worksteal"
+
python_foreach_impl meson_src_test --no-rebuild --verbose
}
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index ec4db2e48278..752d29f03855 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE='bzip2(+),threads(+)'
TMPFILES_OPTIONAL=1
-inherit meson linux-info python-r1 tmpfiles
+inherit meson linux-info multiprocessing python-r1 tmpfiles
DESCRIPTION="The package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
@@ -37,7 +37,10 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/setuptools[${PYTHON_USEDEP}]
' python3_12)
- test? ( dev-vcs/git )
+ test? (
+ dev-vcs/git
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
"
DEPEND="
${PYTHON_DEPS}
@@ -153,6 +156,8 @@ src_compile() {
}
src_test() {
+ local -x PYTEST_ADDOPTS="-vv -ra -l -o console_output_style=count -n $(makeopts_jobs) --dist=worksteal"
+
python_foreach_impl meson_src_test --no-rebuild --verbose
}