summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-01-21 00:54:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-01-21 00:56:21 +0100
commitb6b6c5619f4a135836266281d5b5e64947e769ed (patch)
tree7d996c67974f60eb4b8333d824402ff4fd10c704 /sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild
parentmedia-libs/gmmlib: add 22.0.1 (diff)
downloadgentoo-b6b6c5619f4a135836266281d5b5e64947e769ed.tar.gz
gentoo-b6b6c5619f4a135836266281d5b5e64947e769ed.tar.bz2
gentoo-b6b6c5619f4a135836266281d5b5e64947e769ed.zip
sys-auth/AusweisApp2: add 1.22.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild
new file mode 100644
index 000000000000..fd2f4d5730d0
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.22.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}