summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleksandr Trotsenko <oleksandr.trotsenko@gmail.com>2018-08-28 19:01:13 -0500
committerCraig Andrews <candrews@gentoo.org>2018-08-31 14:22:27 -0400
commitdd2af693f55ad8ba61d04d6c468eb36e03818f59 (patch)
tree15f67fef5b45d4fa93a2cb1478526bfc65519a43 /sys-auth/authenticator/authenticator-0.2.1.ebuild
parentdev-python/pyzbar: Introducing support for Python3.7 (diff)
downloadgentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.tar.gz
gentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.tar.bz2
gentoo-dd2af693f55ad8ba61d04d6c468eb36e03818f59.zip
sys-auth/authenticator: Move package from gnome-extra/ category
Moving the recently introduced package to a more appropriate category, namely from gnome-extra/authenticator to sys-auth/authenticator. Also drop Python 3.4 Closes: https://bugs.gentoo.org/663820 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-auth/authenticator/authenticator-0.2.1.ebuild')
-rw-r--r--sys-auth/authenticator/authenticator-0.2.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-auth/authenticator/authenticator-0.2.1.ebuild b/sys-auth/authenticator/authenticator-0.2.1.ebuild
new file mode 100644
index 000000000000..f11556202d24
--- /dev/null
+++ b/sys-auth/authenticator/authenticator-0.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit gnome2-utils meson python-r1 virtualx xdg-utils
+
+DESCRIPTION="Two-factor authentication code generator for GNOME"
+HOMEPAGE="https://github.com/bilelmoussaoui/Authenticator"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="https://github.com/bilelmoussaoui/Authenticator/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/Authenticator-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ app-crypt/libsecret
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pyotp[${PYTHON_USEDEP}]
+ dev-python/pyzbar[${PYTHON_USEDEP}]
+ media-gfx/gnome-screenshot
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/disable-failing-tests.patch" )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+src_test() {
+ xdg_environment_reset
+ virtx meson_src_test
+}