summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-10-20 14:49:37 +0800
committerJason Zaman <perfinion@gentoo.org>2015-10-20 14:51:32 +0800
commited5ecc21878a78ced639c2e82e76c75c1d63be68 (patch)
tree04aa255d72957d38231f3c6663752dd989a5ae45 /sys-auth/consolekit/consolekit-9999.ebuild
parentdev-ruby/mixlib-shellout: add 2.2.2 (diff)
downloadgentoo-ed5ecc21878a78ced639c2e82e76c75c1d63be68.tar.gz
gentoo-ed5ecc21878a78ced639c2e82e76c75c1d63be68.tar.bz2
gentoo-ed5ecc21878a78ced639c2e82e76c75c1d63be68.zip
sys-auth/consolekit: Update live ebuild
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-auth/consolekit/consolekit-9999.ebuild')
-rw-r--r--sys-auth/consolekit/consolekit-9999.ebuild23
1 files changed, 18 insertions, 5 deletions
diff --git a/sys-auth/consolekit/consolekit-9999.ebuild b/sys-auth/consolekit/consolekit-9999.ebuild
index 0be1ac7f9c3c..a70faad4b8c1 100644
--- a/sys-auth/consolekit/consolekit-9999.ebuild
+++ b/sys-auth/consolekit/consolekit-9999.ebuild
@@ -16,21 +16,26 @@ EGIT_REPO_URI="https://github.com/${MY_PN}/${MY_PN}.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="acl debug doc kernel_linux pam policykit selinux test"
+IUSE="acl cgroups debug doc kernel_linux pam policykit selinux test"
-COMMON_DEPEND=">=dev-libs/glib-2.40:2=
+COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
+ >=sys-devel/gettext-0.19
+ sys-apps/dbus
sys-libs/zlib:=
x11-libs/libX11:=
acl? (
sys-apps/acl:=
>=virtual/udev-200
)
+ cgroups? (
+ app-admin/cgmanager
+ >=sys-libs/libnih-1.0.2[dbus]
+ )
pam? ( virtual/pam )
policykit? ( >=sys-auth/polkit-0.110 )"
RDEPEND="${COMMON_DEPEND}
kernel_linux? ( sys-apps/coreutils[acl?] )
- selinux? ( sec-policy/selinux-consolekit )
- sys-power/pm-utils"
+ selinux? ( sec-policy/selinux-consolekit )"
DEPEND="${COMMON_DEPEND}
dev-libs/libxslt
virtual/pkgconfig
@@ -40,6 +45,8 @@ DEPEND="${COMMON_DEPEND}
app-text/xmlto
)"
+S=${WORKDIR}/${MY_P}
+
QA_MULTILIB_PATHS="usr/lib/ConsoleKit/.*"
pkg_setup() {
@@ -75,6 +82,7 @@ src_configure() {
$(use_enable debug) \
$(use_enable policykit polkit) \
$(use_enable acl udev-acl) \
+ $(use_enable cgroups) \
$(use_enable test tests) \
--with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
--with-pam-module-dir="$(getpam_mod_dir)" \
@@ -92,7 +100,7 @@ src_install() {
dodoc AUTHORS HACKING NEWS README TODO
- newinitd "${FILESDIR}"/${PN}-0.2.rc consolekit
+ newinitd "${FILESDIR}"/${PN}-1.0.0.initd consolekit
keepdir /usr/lib/ConsoleKit/run-seat.d
keepdir /usr/lib/ConsoleKit/run-session.d
@@ -109,3 +117,8 @@ src_install() {
insinto /etc/logrotate.d
newins "${WORKDIR}"/debian/${PN}.logrotate ${PN} #374513
}
+
+pkg_postinst() {
+ elog "For suspend/hibernate support, please emerge"
+ elog " sys-power/pm-utils"
+}