summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-03-21 11:07:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-21 11:14:51 +0100
commit17d2478bf0087c3540f5df3dffe477b3dc81e32b (patch)
tree835ee5b7d58e49446b15edfef7531ce851651484 /sys-auth/elogind
parentdev-ros/roslint: Bump to 0.11.1 (diff)
downloadgentoo-17d2478bf0087c3540f5df3dffe477b3dc81e32b.tar.gz
gentoo-17d2478bf0087c3540f5df3dffe477b3dc81e32b.tar.bz2
gentoo-17d2478bf0087c3540f5df3dffe477b3dc81e32b.zip
sys-auth/elogind: 226.4 version bump
Gentoo-bug: 613398 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/Manifest1
-rw-r--r--sys-auth/elogind/elogind-226.4.ebuild84
-rw-r--r--sys-auth/elogind/files/elogind-226.4-docs.patch15
3 files changed, 100 insertions, 0 deletions
diff --git a/sys-auth/elogind/Manifest b/sys-auth/elogind/Manifest
index 77184ebc69a5..c3cf7979c73b 100644
--- a/sys-auth/elogind/Manifest
+++ b/sys-auth/elogind/Manifest
@@ -1 +1,2 @@
DIST elogind-219.12.tar.gz 815956 SHA256 80241494f5c794e8501ccf570ac805275ace368755780f38a18762fd06243f95 SHA512 59b18d43d761d6f4daa25b7a7dfb51b435d8b1ae67515474392f428046b3baa17412b54730745757f0c417edaf280b51bc3f1ad3570ba6d4b0410bfd1a5fdf20 WHIRLPOOL e977d772671e13ce940ca1da6dce133b70527c483e09b63ceccba133b018cdb5eca8b83f5e7dc0e3791aef1efae64cbd15c2c0f02cf50ae00dd26786a7807402
+DIST elogind-226.4.tar.gz 698076 SHA256 585ac8746cd81a74f47b4e93cb5f000494da4104ad53da0bae023e1758d0456d SHA512 4eb4da1d0311b2fe2d22fef57143fe8c2280df9f7a2b41e150f4d7e1411bd41eed4648aa3b80ac44d2b533e8c91a482cda7c3e8af85e710fb97e73061726ea12 WHIRLPOOL 8252b4e54830f9e257a28751eb233d4752cff24b4d695c2351f86cc65160ff6577e373cdd667635e0dee00fb63e1a57a7c049105eef9c5e4cd4cb2a7cc991f63
diff --git a/sys-auth/elogind/elogind-226.4.ebuild b/sys-auth/elogind/elogind-226.4.ebuild
new file mode 100644
index 000000000000..7b284e007ac8
--- /dev/null
+++ b/sys-auth/elogind/elogind-226.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info pam udev
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="acl debug pam policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ !sys-apps/systemd
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+PDEPEND="policykit? ( sys-auth/polkit )"
+
+PATCHES=( "${FILESDIR}/${P}-docs.patch" )
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
+ ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf # Makefile.am patched by "${FILESDIR}/${P}-docs.patch"
+}
+
+src_configure() {
+ econf \
+ --with-pamlibdir=$(getpam_mod_dir) \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --enable-smack \
+ --disable-kdbus \
+ $(use_enable debug debug elogind) \
+ $(use_enable acl) \
+ $(use_enable pam) \
+ $(use_enable selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list default | grep elogind)" = "" ]; then
+ ewarn "To enable the elogind daemon, elogind must be"
+ ewarn "added to the default runlevel:"
+ ewarn "# rc-update add elogind default"
+ fi
+}
diff --git a/sys-auth/elogind/files/elogind-226.4-docs.patch b/sys-auth/elogind/files/elogind-226.4-docs.patch
new file mode 100644
index 000000000000..4161f6331253
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-226.4-docs.patch
@@ -0,0 +1,15 @@
+--- a/Makefile.am 2017-02-16 13:22:56.764985896 +0100
++++ b/Makefile.am 2017-02-16 13:23:04.998986057 +0100
+@@ -194,12 +194,6 @@
+ bin_PROGRAMS =
+ rootlibexec_PROGRAMS =
+
+-dist_doc_DATA = \
+- README \
+- NEWS \
+- LICENSE.LGPL2.1 \
+- LICENSE.GPL2
+-
+ @INTLTOOL_POLICY_RULE@
+
+ # ------------------------------------------------------------------------------