summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-12 22:42:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-12 23:15:26 +0100
commit61b4a84845969c957dbf59135178f2a801ce9ff8 (patch)
tree8d1a52abb8691f1bfd6f781379267325b2c8ac34 /sys-auth/elogind
parentsys-kernel/gentoo-kernel-bin: Bump to 4.19.109 (diff)
downloadgentoo-61b4a84845969c957dbf59135178f2a801ce9ff8.tar.gz
gentoo-61b4a84845969c957dbf59135178f2a801ce9ff8.tar.bz2
gentoo-61b4a84845969c957dbf59135178f2a801ce9ff8.zip
sys-auth/elogind: Fix build with +selinux
Closes: https://bugs.gentoo.org/711432 Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/elogind-243.4.ebuild1
-rw-r--r--sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-auth/elogind/elogind-243.4.ebuild b/sys-auth/elogind/elogind-243.4.ebuild
index 1817a25b51c0..0a185cec6129 100644
--- a/sys-auth/elogind/elogind-243.4.ebuild
+++ b/sys-auth/elogind/elogind-243.4.ebuild
@@ -50,6 +50,7 @@ DOCS=( README.md src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
PATCHES=(
"${FILESDIR}/${P}-nodocs.patch"
"${FILESDIR}/${PN}-241.4-broken-test.patch" # bug 699116
+ "${FILESDIR}/${P}-selinux-missing-headers.patch" # bug 711432
)
pkg_setup() {
diff --git a/sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch b/sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch
new file mode 100644
index 000000000000..7cc46fd05ebd
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-243.4-selinux-missing-headers.patch
@@ -0,0 +1,36 @@
+From 1cd3fe4083eb8784fa2a125e4af0edb80e6928b5 Mon Sep 17 00:00:00 2001
+From: Sven Eden <sven.eden@prydeworx.com>
+Date: Thu, 12 Mar 2020 20:31:00 +0100
+Subject: [PATCH] basic/selinux-util.c : Uncomment missing includes (#157)
+
+Compiling on Debian unstable failed using gcc 9.2.1 and libc6 2.29.
+Uncommenting the two commented includes in basic/selinux-util.c
+fixes the compilation issues.
+
+Bug: #157
+Closes: #157
+Signed-off-by: Sven Eden <sven.eden@prydeworx.com>
+---
+ src/basic/selinux-util.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/basic/selinux-util.c b/src/basic/selinux-util.c
+index 40a85feec..3be9f2c0d 100644
+--- a/src/basic/selinux-util.c
++++ b/src/basic/selinux-util.c
+@@ -1,13 +1,13 @@
+ /* SPDX-License-Identifier: LGPL-2.1+ */
+
+ #include <errno.h>
+-//#include <fcntl.h>
++#include <fcntl.h>
+ #include <malloc.h>
+ #include <stddef.h>
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/time.h>
+-//#include <sys/types.h>
++#include <sys/types.h>
+ #include <sys/un.h>
+ #include <syslog.h>
+