summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-04 15:03:38 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-04 15:33:47 +0000
commit0c5cfaaa0c78b182a406536fbe22265482974a56 (patch)
tree7aa0935874774cfa5efe32f0f527cc8639c6e518 /sys-auth/fprintd
parentsys-auth/libfprint: add 1.94.2 (diff)
downloadgentoo-0c5cfaaa0c78b182a406536fbe22265482974a56.tar.gz
gentoo-0c5cfaaa0c78b182a406536fbe22265482974a56.tar.bz2
gentoo-0c5cfaaa0c78b182a406536fbe22265482974a56.zip
sys-auth/fprintd: add 1.94.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth/fprintd')
-rw-r--r--sys-auth/fprintd/Manifest1
-rw-r--r--sys-auth/fprintd/fprintd-1.94.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/sys-auth/fprintd/Manifest b/sys-auth/fprintd/Manifest
index 9360412d9a69..b3795ab22ad1 100644
--- a/sys-auth/fprintd/Manifest
+++ b/sys-auth/fprintd/Manifest
@@ -3,3 +3,4 @@ DIST fprintd-v1.90.8.tar.bz2 635139 BLAKE2B 4f9e5c395c32dd5de3f5ed4d17e81c28a55d
DIST fprintd-v1.90.9.tar.bz2 636538 BLAKE2B 8a2150887282aae722d143ec96a9c0c3b5dd066e4cba30c41d49b6f6afe95c26c585aec2d9b074d65dd1a3efd462dae294a98965a020c4e55a8cda7c00a827bb SHA512 2b0f3e5812dd29df2b78ff6082c75981c28af71fc07e19e7eb4743842562e7d5bfc0655d5fbb66bfb167bc3087100bd0f154257ad936eab03e9e8ccc2410481f
DIST fprintd-v1.92.0.tar.bz2 651377 BLAKE2B 39db660e3203b08c1233b9711f56c5b4539f1dff4f8cd9554dce4ce055e2fd2a63dc5e8792808232f86906bf1b7d15a7f155e67ddd49a98ff92ac75b4bd712f4 SHA512 e3fcf948321bf82398f06cca33cb29745c7fc38421025c9340dc85ba2ffb87e63f9546aae721ae72ad0c6f4268a856d60cd57089238d5c92e14b31de215f17d1
DIST fprintd-v1.94.0.tar.bz2 656308 BLAKE2B f64f92af51f2d3eda059640cdfa88b26ca12326b3082e9489f6d807ec566aced86e1d19a59ad247ec2aaa6e6a90dd3d030c18e062e39143a1d4110e62e7ad03d SHA512 1ab8cf93d10317201c3f83880b9e6de4a391c2a12afe29725ae3556a7b0108a374eb96f6b2b5be69c01c386f62e3543e3f9a974867256c99e690dd19bdd5778d
+DIST fprintd-v1.94.1.tar.bz2 658149 BLAKE2B 734da268e308b08b04cbc661d889f52c4e8b2dd61d7a67961eaba5a6aa130f6972525820a17e8b6dd53d38508629139a5a0be20b69eaea45430cc60da5cd9a27 SHA512 ff22087e09ab9f75e458e71f595d611ea97240596a25bd96f41a0fb1de865336f8c2edbd49d5e7c8132a7e554d8311337ec02991dde358cba1962d4cb182447d
diff --git a/sys-auth/fprintd/fprintd-1.94.1.ebuild b/sys-auth/fprintd/fprintd-1.94.1.ebuild
new file mode 100644
index 000000000000..8a0c86a78391
--- /dev/null
+++ b/sys-auth/fprintd/fprintd-1.94.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson pam python-any-r1 systemd
+
+MY_P="${PN}-v${PV}"
+DESCRIPTION="D-Bus service to access fingerprint readers"
+HOMEPAGE="https://gitlab.freedesktop.org/libfprint/fprintd"
+SRC_URI="https://gitlab.freedesktop.org/libfprint/${PN}/-/archive/v${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc pam systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ >=sys-auth/libfprint-1.94.0:2
+ sys-auth/polkit
+ pam? (
+ sys-libs/pam
+ systemd? ( sys-apps/systemd )
+ !systemd? ( sys-auth/elogind )
+ )"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ pam? ( sys-libs/pam_wrapper[${PYTHON_USEDEP}] )
+ ')
+ )"
+
+BDEPEND="
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-util/gtk-doc
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.90.7_0001-add-test-feature-and-make-tests-optional.patch"
+ "${FILESDIR}/${PN}-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+python_check_deps() {
+ if use test; then
+ has_version -d "sys-libs/pam_wrapper[${PYTHON_USEDEP}]"
+ fi
+
+ has_version -d "dev-python/python-dbusmock[${PYTHON_USEDEP}]" &&
+ has_version -d "dev-python/dbus-python[${PYTHON_USEDEP}]" &&
+ has_version -d "dev-python/pycairo[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test)
+ $(meson_use pam)
+ -Dgtk_doc=$(usex doc true false)
+ -Dman=true
+ -Dsystemd_system_unit_dir=$(systemd_get_systemunitdir)
+ -Dpam_modules_dir=$(getpam_mod_dir)
+ -Dlibsystemd=$(usex systemd libsystemd libelogind)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ dodoc AUTHORS NEWS README TODO
+ newdoc pam/README README.pam_fprintd
+}
+
+pkg_postinst() {
+ elog "Please take a look at README.pam_fprintd for integration docs."
+}