summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-01-08 11:09:07 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2021-01-08 11:09:23 -0600
commit7c1b363ca1aecbe5c0c878d5d6583d869b01d073 (patch)
tree5dc18e93c4659db117ce00c638811f5aa5c66194 /sys-auth/fprintd
parentgnome-extra/gnome-clocks: Fix installation (diff)
downloadgentoo-7c1b363ca1aecbe5c0c878d5d6583d869b01d073.tar.gz
gentoo-7c1b363ca1aecbe5c0c878d5d6583d869b01d073.tar.bz2
gentoo-7c1b363ca1aecbe5c0c878d5d6583d869b01d073.zip
sys-auth/fprintd: 1.90.8 bump
tested locally, seems fine Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'sys-auth/fprintd')
-rw-r--r--sys-auth/fprintd/Manifest1
-rw-r--r--sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch75
-rw-r--r--sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch24
-rw-r--r--sys-auth/fprintd/fprintd-1.90.8.ebuild76
4 files changed, 176 insertions, 0 deletions
diff --git a/sys-auth/fprintd/Manifest b/sys-auth/fprintd/Manifest
index c0a22b06a9dc..7995d31c2bec 100644
--- a/sys-auth/fprintd/Manifest
+++ b/sys-auth/fprintd/Manifest
@@ -1 +1,2 @@
DIST fprintd-0.8.1.tar.bz2 75254 BLAKE2B bf59c47c3d0186677bfd180e472e13773afebd4c3438e0e8e8cce34156df1c64c142b73d541fa876b96d4881e6967745a8c29be310dd33a509cb1863c836634e SHA512 438098fb677b742fdb279f3df85a1f2c800fce7498130c09b7408f21656ff256323b3bce4c22a2499e52c2ca7cddbc7f26033be7869939d23f9b5c436aa1f252
+DIST fprintd-v1.90.8.tar.bz2 635139 BLAKE2B 4f9e5c395c32dd5de3f5ed4d17e81c28a55de0f411deb3ccbc5d1330129be2bc8263c63c61a5e4910f74e49ebbbf508e858f5ee131eb4552e2ea8ab167bc6021 SHA512 0f38e0ce9f7c1459ba5359d0834569fe5d3f5ec3c9499d008dc39b9c869bbfa1cb293b1d96d22f9f36708f26984a1b3f0776685d628df69f1ed6db14de04a489
diff --git a/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch b/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch
new file mode 100644
index 000000000000..95428184c2f5
--- /dev/null
+++ b/sys-auth/fprintd/files/fprintd-1.90.7_0001-add-test-feature-and-make-tests-optional.patch
@@ -0,0 +1,75 @@
+From 7820465f078e9655af70036d8c570fd644b38f22 Mon Sep 17 00:00:00 2001
+From: Martin Gysel <me@bearsh.org>
+Date: Thu, 19 Nov 2020 07:04:10 +0100
+Subject: [PATCH 1/2] add test feature and make tests optional
+
+---
+ meson.build | 14 ++++++++++----
+ meson_options.txt | 4 ++++
+ 2 files changed, 14 insertions(+), 4 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 66aa2f7..ba44788 100644
+--- a/meson.build
++++ b/meson.build
+@@ -125,7 +125,7 @@ endif
+ polkit_policy_directory = polkit_gobject_dep.get_pkgconfig_variable('policydir')
+
+ # Tests dependencies
+-pam_wrapper_dep = dependency('pam_wrapper', required: get_option('pam'))
++pam_wrapper_dep = dependency('pam_wrapper', required: get_option('pam') and get_option('test').enabled() )
+
+ xmllint = find_program('xmllint', required: false)
+ python3 = find_program('python3') # No meson without it!
+@@ -139,11 +139,13 @@ python3_test_modules = {
+ }
+ python3_available_modules = []
+
++if get_option('test').enabled()
+ foreach module, required : python3_test_modules
+ if required and run_command(python3, '-c', 'import @0@'.format(module)).returncode() != 0
+ error('Python3 module \'' + module + '\' required by test suite not found')
+ endif
+ endforeach
++endif
+
+ cdata = configuration_data()
+ cdata.set_quoted('GETTEXT_PACKAGE', meson.project_name())
+@@ -167,7 +169,9 @@ endif
+ if get_option('gtk_doc')
+ subdir('doc')
+ endif
+-subdir('tests')
++if get_option('test').enabled()
++ subdir('tests')
++endif
+ subdir('po')
+
+ output = []
+@@ -189,7 +193,9 @@ output += ' PAM module: ' + pam_dep.found().to_string()
+ output += ' Manuals: ' + get_option('man').to_string()
+ output += ' GTK Doc: ' + get_option('gtk_doc').to_string()
+ output += ' XML Linter ' + xmllint.found().to_string()
+-output += '\nTest setup:\n'
+-output += ' With address sanitizer: ' + address_sanitizer.to_string()
++if get_option('test').enabled()
++ output += '\nTest setup:\n'
++ output += ' With address sanitizer: ' + address_sanitizer.to_string()
++endif
+
+ message('\n'+'\n'.join(output)+'\n')
+diff --git a/meson_options.txt b/meson_options.txt
+index be31fe1..92c01cd 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -19,3 +19,7 @@ option('gtk_doc',
+ type: 'boolean',
+ value: false,
+ description: 'Use gtk-doc to build documentation')
++option('test',
++ type: 'feature',
++ value: 'disabled',
++ description: 'Enable tests')
+--
+2.29.2
+
diff --git a/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch b/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch
new file mode 100644
index 000000000000..a10026f33466
--- /dev/null
+++ b/sys-auth/fprintd/files/fprintd-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch
@@ -0,0 +1,24 @@
+--- fprintd-v1.90.8/meson.build.orig 2020-12-13 08:08:13.886367478 +0100
++++ fprintd-v1.90.8/meson.build 2020-12-13 08:30:16.056756878 +0100
+@@ -84,7 +84,7 @@
+ libfprint_dep = dependency('libfprint-2', version: '>=' + libfprint_min_version)
+ polkit_gobject_dep = dependency('polkit-gobject-1', version: '>= 0.91')
+ dbus_dep = dependency('dbus-1', required: false)
+-libsystemd_dep = dependency('libsystemd', required: get_option('pam'))
++libsystemd_dep = dependency(get_option('libsystemd'), required: get_option('pam'))
+ pam_dep = cc.find_library('pam',
+ required: get_option('pam'),
+ has_headers: 'security/pam_modules.h',
+--- fprintd-v1.90.8/meson_options.txt.orig 2020-12-13 08:08:13.886367478 +0100
++++ fprintd-v1.90.8/meson_options.txt 2020-12-13 08:26:57.111919403 +0100
+@@ -10,6 +10,10 @@
+ description: 'Install system service files',
+ type: 'boolean',
+ value: true)
++option('libsystemd',
++ description: 'Libsystemd provider (libsystemd or libelogind)',
++ type: 'string',
++ value: 'libsystemd')
+ option('systemd_system_unit_dir',
+ description: 'Directory for systemd service files',
+ type: 'string')
diff --git a/sys-auth/fprintd/fprintd-1.90.8.ebuild b/sys-auth/fprintd/fprintd-1.90.8.ebuild
new file mode 100644
index 000000000000..1dcc64b3e959
--- /dev/null
+++ b/sys-auth/fprintd/fprintd-1.90.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson pam systemd
+
+DESCRIPTION="D-Bus service to access fingerprint readers"
+HOMEPAGE="https://gitlab.freedesktop.org/libfprint/fprintd"
+SRC_URI="https://gitlab.freedesktop.org/libfprint/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc pam systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-auth/libfprint:2
+ sys-auth/polkit
+ pam? (
+ systemd? ( sys-apps/systemd )
+ !systemd? ( sys-auth/elogind )
+ sys-libs/pam
+ )
+"
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-util/gtk-doc
+ )
+ test? (
+ dev-python/dbusmock
+ dev-python/dbus-python
+ dev-python/pycairo
+ pam? ( sys-libs/pam_wrapper )
+ )
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.90.7_0001-add-test-feature-and-make-tests-optional.patch"
+ "${FILESDIR}/${PN}-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature test)
+ $(meson_use pam)
+ -Dgtk_doc=$(usex doc true false)
+ -Dman=true
+ -Dsystemd_system_unit_dir=$(systemd_get_systemunitdir)
+ -Dpam_modules_dir=$(getpam_mod_dir)
+ -Dlibsystemd=$(usex systemd libsystemd libelogind)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ dodoc AUTHORS NEWS README TODO
+ newdoc pam/README README.pam_fprintd
+}
+
+pkg_postinst() {
+ elog "Please take a look at README.pam_fprintd for integration docs."
+}