summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:50:39 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-04-21 23:51:15 +0200
commitb1c1e8e9061dacd956220e2078fc0a933e7f3040 (patch)
tree2bde2be7fb98c38b6ca581672714a422bd563e7f /sys-auth/libnss-compat
parentsys-libs/glibc: Remove old (diff)
downloadgentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.tar.gz
gentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.tar.bz2
gentoo-b1c1e8e9061dacd956220e2078fc0a933e7f3040.zip
sys-auth/libnss-compat: Add separate libnss_compat module, bug 627338
Only for people who really, really, really need it... Bug: https://bugs.gentoo.org/627338 Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'sys-auth/libnss-compat')
-rw-r--r--sys-auth/libnss-compat/Manifest1
-rw-r--r--sys-auth/libnss-compat/libnss-compat-1.2.ebuild43
-rw-r--r--sys-auth/libnss-compat/metadata.xml7
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-auth/libnss-compat/Manifest b/sys-auth/libnss-compat/Manifest
new file mode 100644
index 000000000000..d727f6fa84d0
--- /dev/null
+++ b/sys-auth/libnss-compat/Manifest
@@ -0,0 +1 @@
+DIST libnss_compat-1.2.tar.gz 201392 BLAKE2B d78cbd6df1437f95423c90fd9b0c82a974bb79cdb8e09b3bd2a3273aa417b2a0b9950e2ac76bf0e6a8fe384328f180a3182caab2e6b3ce40704c6cf49ea9a55e SHA512 e488c72d5d13f9749293a91f2bc86c06fcc184c2edb7d9335569bc77c7aea1d2874de1d83b13f394f3d0881ec368b5749cf9a5c60f362f7c4c428026c2fc0e53
diff --git a/sys-auth/libnss-compat/libnss-compat-1.2.ebuild b/sys-auth/libnss-compat/libnss-compat-1.2.ebuild
new file mode 100644
index 000000000000..9d01d095eb87
--- /dev/null
+++ b/sys-auth/libnss-compat/libnss-compat-1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="NSS module to provide compat entry support"
+HOMEPAGE="https://github.com/thkukuk/libnss_compat"
+SRC_URI="https://github.com/thkukuk/libnss_compat/archive/libnss_compat-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1+ BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >net-libs/libnsl-0:0=[${MULTILIB_USEDEP}]
+ net-libs/libtirpc:0=[${MULTILIB_USEDEP}]
+ !<sys-libs/glibc-2.26
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+S=${WORKDIR}/libnss_compat-libnss_compat-${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sys-auth/libnss-compat/metadata.xml b/sys-auth/libnss-compat/metadata.xml
new file mode 100644
index 000000000000..fa331094dd33
--- /dev/null
+++ b/sys-auth/libnss-compat/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>toolchain@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>