summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-01 15:53:56 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-01 16:09:43 +0100
commitd64b7f684e7510fe995613f894b2e3c09853d91b (patch)
tree07941615b71630a3acbf6957fbc399300e15e5e4 /sys-auth/openpam
parentsys-auth/openpam: Remove obsolete dep on app-vim/pam-syntax (diff)
downloadgentoo-d64b7f684e7510fe995613f894b2e3c09853d91b.tar.gz
gentoo-d64b7f684e7510fe995613f894b2e3c09853d91b.tar.bz2
gentoo-d64b7f684e7510fe995613f894b2e3c09853d91b.zip
sys-auth/openpam: Bump to EAPI=6
Diffstat (limited to 'sys-auth/openpam')
-rw-r--r--sys-auth/openpam/files/openpam-20130907-module-dir.patch4
-rw-r--r--sys-auth/openpam/openpam-20140912-r2.ebuild48
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-auth/openpam/files/openpam-20130907-module-dir.patch b/sys-auth/openpam/files/openpam-20130907-module-dir.patch
index 01afadbbfb8d..28c4414f9120 100644
--- a/sys-auth/openpam/files/openpam-20130907-module-dir.patch
+++ b/sys-auth/openpam/files/openpam-20130907-module-dir.patch
@@ -1,7 +1,7 @@
diff --git a/openpam-20130907/lib/libpam/openpam_constants.c b/openpam-20130907/lib/libpam/openpam_constants.c
index 1cdd810..f66e469 100644
---- a/openpam-20130907/lib/libpam/openpam_constants.c
-+++ b/openpam-20130907/lib/libpam/openpam_constants.c
+--- a/lib/libpam/openpam_constants.c
++++ b/lib/libpam/openpam_constants.c
@@ -135,8 +135,8 @@ const char *openpam_policy_path[] = {
};
diff --git a/sys-auth/openpam/openpam-20140912-r2.ebuild b/sys-auth/openpam/openpam-20140912-r2.ebuild
new file mode 100644
index 000000000000..50de35c46fe7
--- /dev/null
+++ b/sys-auth/openpam/openpam-20140912-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Open source PAM library"
+HOMEPAGE="http://www.openpam.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND="!sys-libs/pam"
+DEPEND="
+ sys-devel/make
+ dev-lang/perl"
+
+PDEPEND="
+ sys-auth/pambase"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20130907-gentoo.patch"
+ "${FILESDIR}/${PN}-20130907-nbsd.patch"
+ "${FILESDIR}/${PN}-20130907-module-dir.patch"
+)
+
+src_prepare() {
+ sed -i -e 's:-Werror::' "${S}/configure.ac"
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --with-modules-dir=/$(get_libdir)/security
+ )
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc CREDITS HISTORY RELNOTES README
+ find "${D}" -name '*.la' -delete || die
+}