summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-03 00:04:46 +0100
committerSam James <sam@gentoo.org>2022-10-03 01:38:09 +0100
commit5bfa0c9d170e14d5dfa9a174298561432c96ed20 (patch)
treee2b0aec2e4b195ab385bd52464fd2379dfc25fb6 /sys-auth/pam-pgsql
parentdev-util/global: fix build with Clang 16 (diff)
downloadgentoo-5bfa0c9d170e14d5dfa9a174298561432c96ed20.tar.gz
gentoo-5bfa0c9d170e14d5dfa9a174298561432c96ed20.tar.bz2
gentoo-5bfa0c9d170e14d5dfa9a174298561432c96ed20.zip
sys-auth/pam-pgsql: fix build with Clang 16
Closes: https://bugs.gentoo.org/871492 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth/pam-pgsql')
-rw-r--r--sys-auth/pam-pgsql/files/pam-pgsql-0.7.3.2-Fix-crypt-implicit-function-declaration.patch18
-rw-r--r--sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r2.ebuild (renamed from sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild)6
2 files changed, 23 insertions, 1 deletions
diff --git a/sys-auth/pam-pgsql/files/pam-pgsql-0.7.3.2-Fix-crypt-implicit-function-declaration.patch b/sys-auth/pam-pgsql/files/pam-pgsql-0.7.3.2-Fix-crypt-implicit-function-declaration.patch
new file mode 100644
index 000000000000..bf3604fd5670
--- /dev/null
+++ b/sys-auth/pam-pgsql/files/pam-pgsql-0.7.3.2-Fix-crypt-implicit-function-declaration.patch
@@ -0,0 +1,18 @@
+From: Sam James <sam@gentoo.org>
+Date: Sun, 2 Oct 2022 23:55:21 +0100
+Subject: [PATCH] Fix crypt() implicit function declaration
+
+crypt() is POSIX and setting _XOPEN_SOURCE makes glibc inhibit
+defining it w/o _DEFAULT_SOURCE.
+
+Bug: https://bugs.gentoo.org/871492
+--- a/src/backend_pgsql.c
++++ b/src/backend_pgsql.c
+@@ -8,7 +8,6 @@
+ * William Grzybowski <william@agencialivre.com.br>
+ */
+
+-#define _XOPEN_SOURCE 500
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <stdarg.h>
diff --git a/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild b/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r2.ebuild
index 656ce64960a5..cf3ad756ccad 100644
--- a/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r1.ebuild
+++ b/sys-auth/pam-pgsql/pam-pgsql-0.7.3.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,10 @@ RDEPEND=">=dev-db/postgresql-8.0:=
virtual/libcrypt:="
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.3.2-Fix-crypt-implicit-function-declaration.patch
+)
+
src_configure() {
econf \
--sysconfdir=/etc/security \