summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-01-07 15:39:43 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-01-07 15:40:55 -0800
commit10d91c51d8a18cd89df9f397f64a9417db3a1943 (patch)
tree9a2f1eb7c3edb41ab90c093f0164cc5a6ed5a628 /sys-auth/pam-script/pam-script-1.1.9.ebuild
parentvirtual/man: drop keywords based on sys-apps/man and sys-apps/man-db (diff)
downloadgentoo-10d91c51d8a18cd89df9f397f64a9417db3a1943.tar.gz
gentoo-10d91c51d8a18cd89df9f397f64a9417db3a1943.tar.bz2
gentoo-10d91c51d8a18cd89df9f397f64a9417db3a1943.zip
sys-auth/pam-script: Version bump to 1.1.9 (bug #674614)
Closes: https://bugs.gentoo.org/674614 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-auth/pam-script/pam-script-1.1.9.ebuild')
-rw-r--r--sys-auth/pam-script/pam-script-1.1.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/pam-script/pam-script-1.1.9.ebuild b/sys-auth/pam-script/pam-script-1.1.9.ebuild
new file mode 100644
index 000000000000..143addcfc1a5
--- /dev/null
+++ b/sys-auth/pam-script/pam-script-1.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="PAM module for running scripts during authorization, password change and session"
+HOMEPAGE="https://github.com/jeroennijhof/pam_script/"
+SRC_URI="https://github.com/jeroennijhof/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="virtual/pam"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/$(get_libdir)/security \
+ --sysconfdir=/etc/security/${PN}
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ docinto examples
+ dodoc etc/README.examples
+ exeinto /usr/share/doc/${PF}/examples
+ doexe etc/{logscript,tally}
+ docompress -x /usr/share/doc/${PF}/examples/{logscript,tally}
+ fi
+}