summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-12-05 10:50:49 -0500
committerMatt Turner <mattst88@gentoo.org>2020-12-05 13:48:08 -0500
commit2b6f8ffc521f87c21006a3cd8dd509fcf6591d10 (patch)
treedd10d3e021b2172bcd9a44dbdf0f30c7d797b792 /sys-auth/pam_mount
parentdev-lua/lua-argparse: fix mail (diff)
downloadgentoo-2b6f8ffc521f87c21006a3cd8dd509fcf6591d10.tar.gz
gentoo-2b6f8ffc521f87c21006a3cd8dd509fcf6591d10.tar.bz2
gentoo-2b6f8ffc521f87c21006a3cd8dd509fcf6591d10.zip
sys-auth/pam_mount: Version bump to 2.17
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/Manifest1
-rw-r--r--sys-auth/pam_mount/pam_mount-2.17.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/Manifest b/sys-auth/pam_mount/Manifest
index 9ceb07e294c3..8da75b09b756 100644
--- a/sys-auth/pam_mount/Manifest
+++ b/sys-auth/pam_mount/Manifest
@@ -1 +1,2 @@
DIST pam_mount-2.16.tar.xz 312316 BLAKE2B 5954af8f8bf8b9cb47e1c07dc0d5fc5c4db099eeca5de90a3a53dc65aac0a2a6fba3f99c4d91d12f53b13abb5d3bae262b42536434553872a36ec108dc8d2c0c SHA512 3a579d7287cfcaef831d3e54d3e912407b65a966303e81c47f445d601f38f866ce04326e3d37a061f74f97b9cfb201e56109f57e55699d15d8f947ae2b91c8e3
+DIST pam_mount-2.17.tar.xz 326948 BLAKE2B b5d8c5701bfa4e3ce50ca71b1130d5f68655df12ac45cf554f38f2625b33fcece895d4b67d79cea2ad735c4994c779844dfc5266872e054a1e6d078632f3370c SHA512 d55d2a0e99d51ef649845548e4178b9b34db9c742c592e0ba97359646281af17795080e6ecb1a2a11bc680d31f2c77e69261f731de8f68e8602bcd838371927f
diff --git a/sys-auth/pam_mount/pam_mount-2.17.ebuild b/sys-auth/pam_mount/pam_mount-2.17.ebuild
new file mode 100644
index 000000000000..94b7039acb80
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.17.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt libressl ssl selinux"
+
+DEPEND="
+ >=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1:=
+ >=sys-apps/util-linux-2.20:=
+ >=dev-libs/libxml2-2.6:=
+ >=dev-libs/libpcre-7:=
+ crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/pam_mount-2.16-remove-obsolete-openssl-api.patch
+)
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+
+ # Remove unused nonstandard run-dir, current version uses
+ # FHS-compatible /run, but has leftover mkdir from old version
+ rm -r "${D}/var/lib"
+
+ find "${ED}" -name '*.la' -delete || die
+}