summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2022-04-12 13:46:14 +0200
committerHanno Böck <hanno@gentoo.org>2022-04-12 13:46:14 +0200
commit97558f858a1ae18b792716b4f68e0bc2b30f69fe (patch)
treec12a162e1c3a063d7fddf60a85766861326ea135 /sys-auth/pam_mount
parentdev-python/gpep517: Bump to v3 (diff)
downloadgentoo-97558f858a1ae18b792716b4f68e0bc2b30f69fe.tar.gz
gentoo-97558f858a1ae18b792716b4f68e0bc2b30f69fe.tar.bz2
gentoo-97558f858a1ae18b792716b4f68e0bc2b30f69fe.zip
sys-auth/pam_mount: Depend on libpcre2.
We were still depending on old libpcre, although upstream already changed the API to libpcre2. Bug: https://bugs.gentoo.org/837983 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'sys-auth/pam_mount')
-rw-r--r--sys-auth/pam_mount/pam_mount-2.18-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-auth/pam_mount/pam_mount-2.18-r1.ebuild b/sys-auth/pam_mount/pam_mount-2.18-r1.ebuild
new file mode 100644
index 000000000000..03fcbd7cc704
--- /dev/null
+++ b/sys-auth/pam_mount/pam_mount-2.18-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A PAM module that can mount volumes for a user session"
+HOMEPAGE="http://pam-mount.sourceforge.net"
+SRC_URI="mirror://sourceforge/pam-mount/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="crypt ssl selinux"
+
+DEPEND="
+ >=sys-libs/pam-0.99
+ >=sys-libs/libhx-3.12.1:=
+ >=sys-apps/util-linux-2.20:=
+ >=dev-libs/libxml2-2.6:=
+ dev-libs/libpcre2
+ crypt? ( >=sys-fs/cryptsetup-1.1.0:= )
+ ssl? ( dev-libs/openssl:0= )
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/pam_mount-2.16-remove-obsolete-openssl-api.patch
+)
+
+src_configure() {
+ econf --with-slibdir="/$(get_libdir)" \
+ $(use_with crypt cryptsetup) \
+ $(use_with ssl crypto) \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ use selinux || rm -r "${D}"/etc/selinux
+ dodoc doc/*.txt
+
+ # Remove unused nonstandard run-dir, current version uses
+ # FHS-compatible /run, but has leftover mkdir from old version
+ rm -r "${D}/var/lib"
+
+ find "${ED}" -name '*.la' -delete || die
+}