summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-auth/pam_mysql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-auth/pam_mysql')
-rw-r--r--sys-auth/pam_mysql/Manifest1
-rw-r--r--sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff9
-rw-r--r--sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff10
-rw-r--r--sys-auth/pam_mysql/metadata.xml11
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild39
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild46
6 files changed, 116 insertions, 0 deletions
diff --git a/sys-auth/pam_mysql/Manifest b/sys-auth/pam_mysql/Manifest
new file mode 100644
index 000000000000..0a9d6512e7a6
--- /dev/null
+++ b/sys-auth/pam_mysql/Manifest
@@ -0,0 +1 @@
+DIST pam_mysql-0.7RC1.tar.gz 335240 SHA256 cb3cf89b9b51cb196ee8d731f85acbab72b4878a3a7c4183c5534161d4385ce7 SHA512 c057999c62d29dfa7a07db9a8d33d0cf0377dae4770c73019bd85f67c9c92fc9dac36fa606739162a5f7b0f9fbd849e5833fee827febfe4af883b8c2ddbd8b4f WHIRLPOOL 4d47d4be6c95ad70705884f2023975a719d06915ac41738d7c28ceff2d57e0c58187b52314e1f11e0e4bcfe3b3471525a3e97591d653342847f1d2ed66ecdc57
diff --git a/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff
new file mode 100644
index 000000000000..0b32b37e9e05
--- /dev/null
+++ b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-link-to-pam.diff
@@ -0,0 +1,9 @@
+--- pam_mysql-0.7RC1/Makefile.am 2005-09-20 07:43:44.000000000 +0200
++++ pam_mysql-0.7RC1-1/Makefile.am 2011-09-13 09:21:53.198200066 +0200
+@@ -3,5 +3,6 @@
+ noinst_FILES=pam_mysql.la pam_mysql.a
+ pam_mysql_la_SOURCES=pam_mysql.c
+ pam_mysql_la_LDFLAGS=-module -avoid-version
++pam_mysql_la_LIBADD=-lpam
+ INCLUDES=@INCLUDES@
+ EXTRA_DIST=COPYING NEWS README CREDITS ChangeLog INSTALL pam_mysql.spec.in install-sh missing mkinstalldirs pkg.m4 pam_mysql.spec
diff --git a/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff
new file mode 100644
index 000000000000..e746be72029d
--- /dev/null
+++ b/sys-auth/pam_mysql/files/pam_mysql-0.7_rc1-memleak.diff
@@ -0,0 +1,10 @@
+--- pam_mysql-0.7RC1/pam_mysql.c 2006-01-09 11:35:59.000000000 +0100
++++ pam_mysql-0.7RC1-1/pam_mysql.c 2011-10-18 20:26:38.655425994 +0200
+@@ -2338,6 +2338,7 @@
+ }
+
+ mysql_close(ctx->mysql_hdl);
++ mysql_library_end();
+
+ xfree(ctx->mysql_hdl);
+ ctx->mysql_hdl = NULL;
diff --git a/sys-auth/pam_mysql/metadata.xml b/sys-auth/pam_mysql/metadata.xml
new file mode 100644
index 000000000000..54820a93fe8c
--- /dev/null
+++ b/sys-auth/pam_mysql/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>mysql</herd>
+ <use>
+ <flag name="openssl">Use OpenSSL for md5 and sha1 support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pam-mysql</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild
new file mode 100644
index 000000000000..a7c79a131e17
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools libtool pam eutils
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND=">=sys-libs/pam-0.72 virtual/mysql"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~sparc x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-link-to-pam.diff"
+ epatch "${FILESDIR}/${P}-memleak.diff"
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_with openssl)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(getpam_mod_dir)" install || die "install failed"
+ rm "${D}/$(getpam_mod_dir)/pam_mysql.la" || die "Failed to remove pam_mysql.la"
+ dodoc CREDITS ChangeLog NEWS README
+}
diff --git a/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild
new file mode 100644
index 000000000000..8d0f58c02614
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.7_rc1-r5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools-utils pam
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="http://pam-mysql.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/pam-mysql/${P/_rc/RC}.tar.gz"
+DEPEND="
+ openssl? ( dev-libs/openssl:0= )
+ >=sys-libs/pam-0.72:0=
+ virtual/mysql:0=
+ "
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86"
+IUSE="openssl"
+S="${WORKDIR}/${P/_rc/RC}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-link-to-pam.diff"
+ "${FILESDIR}/${P}-memleak.diff"
+ )
+DOCS=( CREDITS ChangeLog NEWS README )
+AUTOTOOLS_AUTORECONF="yes"
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
+
+src_prepare() {
+ # Update autotools deprecated file name and macro for bug 468750
+ mv configure.in configure.ac || die "configure rename failed"
+ sed -i s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/ configure.ac || die "sed failed"
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with openssl) )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install libdir="$(getpam_mod_dir)"
+}