summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-05-17 22:14:24 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2019-05-17 22:15:22 +0300
commit77378ffef5ca28c1c4f9c1da7c245b0b31424a87 (patch)
treea7ba862661e440b80296dbfa8555ea6a7fb34558 /sys-auth/pam_p11/pam_p11-0.3.0.ebuild
parentdev-libs/libxslt: stable 1.1.33-r1 for sparc, bug #684206 (diff)
downloadgentoo-77378ffef5ca28c1c4f9c1da7c245b0b31424a87.tar.gz
gentoo-77378ffef5ca28c1c4f9c1da7c245b0b31424a87.tar.bz2
gentoo-77378ffef5ca28c1c4f9c1da7c245b0b31424a87.zip
sys-auth/pam_p11: version bump
Closes: https://bugs.gentoo.org/show_bug.cgi?id=686088 Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.3.0.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.3.0.ebuild b/sys-auth/pam_p11/pam_p11-0.3.0.ebuild
new file mode 100644
index 000000000000..0bcd0d266656
--- /dev/null
+++ b/sys-auth/pam_p11/pam_p11-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pam
+
+DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
+HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
+SRC_URI="https://github.com/OpenSC/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="virtual/pam
+ dev-libs/libp11:=
+ dev-libs/openssl:0="
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf --with-pamdir="$(getpam_mod_dir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}