summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-02-23 02:20:42 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-02-23 02:21:33 +0300
commit7bfc7678187b8a54be7082813a6587ad2db6985a (patch)
tree33f5dc0d051bcac9f675a254fe55d7111d862c79 /sys-auth/passwdqc/passwdqc-2.0.0.ebuild
parentapp-admin/gopass: Drop old (diff)
downloadgentoo-7bfc7678187b8a54be7082813a6587ad2db6985a.tar.gz
gentoo-7bfc7678187b8a54be7082813a6587ad2db6985a.tar.bz2
gentoo-7bfc7678187b8a54be7082813a6587ad2db6985a.zip
sys-auth/passwdqc: Version bump (v2.0.0)
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-auth/passwdqc/passwdqc-2.0.0.ebuild')
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/passwdqc/passwdqc-2.0.0.ebuild b/sys-auth/passwdqc/passwdqc-2.0.0.ebuild
new file mode 100644
index 000000000000..1345d1d8e616
--- /dev/null
+++ b/sys-auth/passwdqc/passwdqc-2.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Password strength checking library (and PAM module)"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/${PN}/${P}.tar.gz"
+
+LICENSE="Openwall BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-libs/pam"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/$(get_libdir)/security/pam_passwdqc.so
+ /usr/$(get_libdir)/libpasswdqc.so.0"
+}
+
+src_prepare() {
+ default
+ sed -i -e 's:`uname -s`:Linux:' Makefile || die
+
+ # ship our own default settings
+ cat <<- EOF > "${S}/passwdqc.conf"
+ min=8,8,8,8,8
+ max=40
+ passphrase=3
+ match=4
+ similar=deny
+ random=47
+ enforce=everyone
+ retry=3
+ EOF
+
+}
+
+_emake() {
+ emake -j1 \
+ SHARED_LIBDIR="/usr/$(get_libdir)" \
+ SECUREDIR="$(getpam_mod_dir)" \
+ CONFDIR="/etc/security" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake pam utils
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install_lib install_pam install_utils
+ dodoc README PLATFORMS INTERNALS
+}