summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-26 12:51:04 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-26 12:51:31 +0200
commit4cf849e26979b741882c6d45cc97f23b263f3738 (patch)
tree05a29ee2f20c2fa2fafeb7792ad00222242ab1c0 /sys-auth/solo-python
parentsys-auth/solo-python: drop 0.0.26 (diff)
downloadgentoo-4cf849e26979b741882c6d45cc97f23b263f3738.tar.gz
gentoo-4cf849e26979b741882c6d45cc97f23b263f3738.tar.bz2
gentoo-4cf849e26979b741882c6d45cc97f23b263f3738.zip
sys-auth/solo-python: add 0.0.28
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-auth/solo-python')
-rw-r--r--sys-auth/solo-python/Manifest1
-rw-r--r--sys-auth/solo-python/solo-python-0.0.28.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-auth/solo-python/Manifest b/sys-auth/solo-python/Manifest
index 1f33a27ac54d..b6b4d04bb6b4 100644
--- a/sys-auth/solo-python/Manifest
+++ b/sys-auth/solo-python/Manifest
@@ -1 +1,2 @@
DIST solo-python-0.0.27.tar.gz 35657 BLAKE2B 747d8849ad4bdda7c0e4b079dce2d7162f07dad4784bb941242dd8ea759cccd763537cec2c7cd9ecf6f467c771729217648b72aa36292622f5fc3adb8a0c280c SHA512 50d564916e07a0c65a843bd2d0328a735ba71eadcfc893b13fac84a3e51822ed2bf80fc3f7662943a5635c6cd6b3ded8ba5b5a9ac2282c9f9bcdfe9de191e445
+DIST solo-python-0.0.28.tar.gz 34818 BLAKE2B 788d71d2641848c0e01640a87c4b20462ba3380a9005a9ab2d4452575bd4ddb560e677538a4ba42e24f9b7f282b0f7a03ce151e2823d3613ff4f93d00bc20524 SHA512 f0af3c350554fc9724f7130566019fc0b0292cbdb9035a9afa602df12e655f63b03f966605bd4b29ee5c07b0b421e9515b7ec612411d4423940461628843716f
diff --git a/sys-auth/solo-python/solo-python-0.0.28.ebuild b/sys-auth/solo-python/solo-python-0.0.28.ebuild
new file mode 100644
index 000000000000..a0767f1bb325
--- /dev/null
+++ b/sys-auth/solo-python/solo-python-0.0.28.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Python tool and library for SoloKeys"
+HOMEPAGE="https://github.com/solokeys/solo-python"
+SRC_URI="https://github.com/solokeys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/click-7.1.0[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ >=dev-python/fido2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/intelhex[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # For some reason the version file gets omitted by src_install (a bug in pyproject2setuppy?),
+ # and in any case there is no advantage to using one once a specific version has been released.
+ sed -i -e "s/^__version__ = open(.\+$/__version__ = '${PV}'/" solo/__init__.py || die "Failed to set the version number"
+ distutils-r1_src_prepare
+}