summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-05 17:30:43 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-05 17:35:29 +0200
commit2ac915e3420ee11837d5c3e9e512b49b544c1160 (patch)
treeb724a7a245eec70c64996a4bab8584e53c83b8dc /sys-auth/ykpers/ykpers-1.19.3-r1.ebuild
parentwww-client/opera: Version 60.0.3255.151 (diff)
downloadgentoo-2ac915e3420ee11837d5c3e9e512b49b544c1160.tar.gz
gentoo-2ac915e3420ee11837d5c3e9e512b49b544c1160.tar.bz2
gentoo-2ac915e3420ee11837d5c3e9e512b49b544c1160.zip
sys-auth/ykpers: Revbump to remove elogind USE flag.
It turned out, one udev rule requires udev-acl from consolekit... Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-auth/ykpers/ykpers-1.19.3-r1.ebuild')
-rw-r--r--sys-auth/ykpers/ykpers-1.19.3-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-auth/ykpers/ykpers-1.19.3-r1.ebuild b/sys-auth/ykpers/ykpers-1.19.3-r1.ebuild
new file mode 100644
index 000000000000..4db6dbd05bb2
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.19.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="consolekit static-libs"
+
+DEPEND="
+ dev-libs/json-c:=
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${DEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )
+"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --libdir=/usr/$(get_libdir)
+ --localstatedir=/var
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ udev_dorules 69-yubikey.rules
+ if use consolekit ; then
+ udev_dorules 70-yubikey.rules
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}