summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-06-08 11:10:43 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-06-08 11:13:01 +0200
commit082e7f00cd5c4e822449ef6a7e2fe4b0c59e6d4a (patch)
treee540c706580089285f41aee2ae3d0dceb9736c74 /sys-auth
parentx11-terms/xterm: add 368 (diff)
downloadgentoo-082e7f00cd5c4e822449ef6a7e2fe4b0c59e6d4a.tar.gz
gentoo-082e7f00cd5c4e822449ef6a7e2fe4b0c59e6d4a.tar.bz2
gentoo-082e7f00cd5c4e822449ef6a7e2fe4b0c59e6d4a.zip
sys-auth/pam_mysql: bump to v0.8.2
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/pam_mysql/Manifest1
-rw-r--r--sys-auth/pam_mysql/pam_mysql-0.8.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/pam_mysql/Manifest b/sys-auth/pam_mysql/Manifest
index 6f2c805ba2c6..03adbed3fb5a 100644
--- a/sys-auth/pam_mysql/Manifest
+++ b/sys-auth/pam_mysql/Manifest
@@ -1 +1,2 @@
DIST pam_mysql-0.8.1.tar.gz 49613 BLAKE2B 1e3f6b0c8a11c8d328300fc820ddbbcd1601735de611e9317aab8f26ab2fbcf0f704e7a2c26de347fe9c4088c8171f0c278cd92e1668671871e5cd79db981241 SHA512 68aecc83c026c7616211a46b80f96fe822c8bd069a5ab6e9b170607bddac0dabe20410f78a1ac61ca1c1b2724ed0f0d99694d34bf28763270da3771c9ef05faf
+DIST pam_mysql-0.8.2.tar.gz 55023 BLAKE2B 2b278dc8cff229dd9fe9da2316f51838e6b9d57714dc07c7dfe85142ac4bb2e6c3a3de7eed7ab34917c08a07197c187434211cb7841c85f4c8d2d088309bae3a SHA512 268dd721554bc15125b6ea95b3f7b7a5f4ebf772e0ad65b6cf53d7e23d6154f10d916da774ea338a6b75427b2a6ada2b4730a57a88a15abea62a0454e7c5ea1e
diff --git a/sys-auth/pam_mysql/pam_mysql-0.8.2.ebuild b/sys-auth/pam_mysql/pam_mysql-0.8.2.ebuild
new file mode 100644
index 000000000000..60c10e4af31a
--- /dev/null
+++ b/sys-auth/pam_mysql/pam_mysql-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools pam
+
+DESCRIPTION="pam_mysql is a module for pam to authenticate users with mysql"
+HOMEPAGE="https://github.com/NigelCunningham/pam-MySQL"
+
+SRC_URI="https://github.com/NigelCunningham/pam-MySQL/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DEPEND="
+ >=sys-libs/pam-0.72:0=
+ dev-db/mysql-connector-c:0=
+ openssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="openssl"
+S="${WORKDIR}/pam-MySQL-${PV}"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-pam-mods-dir="$(getpam_mod_dir)"
+ $(use_with openssl)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}