summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-12-03 16:36:19 -0500
committerCraig Andrews <candrews@gentoo.org>2019-12-03 16:38:42 -0500
commit1caa6552a3a5457f78b88e007481f076e97ccd4d (patch)
tree8fc5d7c3d16213689070db94cb24984d0ca7a21d /sys-auth
parentdev-libs/libfmt: 6.1.0 version bump (diff)
downloadgentoo-1caa6552a3a5457f78b88e007481f076e97ccd4d.tar.gz
gentoo-1caa6552a3a5457f78b88e007481f076e97ccd4d.tar.bz2
gentoo-1caa6552a3a5457f78b88e007481f076e97ccd4d.zip
sys-auth/google-authenticator: 1.07 version bump
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/google-authenticator/Manifest1
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.07.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-auth/google-authenticator/Manifest b/sys-auth/google-authenticator/Manifest
index 761c0d7e8c88..660c726c2698 100644
--- a/sys-auth/google-authenticator/Manifest
+++ b/sys-auth/google-authenticator/Manifest
@@ -1,2 +1,3 @@
DIST google-authenticator-1.05.tar.gz 57778 BLAKE2B c31d7929e2aacffc159ee5384f6f31498585819b848f4f8b026519cf2f2fc566b8533e007844c64d348f1cf423a7175b3221f879c5c1ead360c4f1b3acea57ed SHA512 d97b26c6181dbce0612628484db37b1bf61e984fb2fb3d4974d04038e564404aa17415368dba524f0d17d96ec8d57ae4129b27f0c672d849d16ef03941d87996
DIST google-authenticator-1.06.tar.gz 62292 BLAKE2B 4eb7d6068a1b824c2299fb8d430b2deb04223690fee74a25c8e917e34200630628c3518a5aecc9fd1537d14d86062dc126191c086464b1c6b3d0207676155dc8 SHA512 a278360be1a3c5a03ddb38d40be45dbba16b6f565ee919377a918565bd8c567ce261890dc10d277edea4f469cf1da1d9cf2c9f3ccfeef8c6887d713c785a5440
+DIST google-authenticator-1.07.tar.gz 62764 BLAKE2B 89fa794956bd39f6e1387b0a6ffbdee6b19496771d0e5c47c61c20fc02abaa7c9cd780595556a07cda01d9a6cf6e530752de6f9ac15157213dbb873cadaac010 SHA512 3e2bc9bfc3759f9004d08b1557868a33b628290b62aa9051d21072a66e18ca4b09cdef0fc8303943cb36ac5b61fe864a9de9fe0a1d8677ee86403cfd4c89c1fb
diff --git a/sys-auth/google-authenticator/google-authenticator-1.07.ebuild b/sys-auth/google-authenticator/google-authenticator-1.07.ebuild
new file mode 100644
index 000000000000..a087b7c55504
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.07.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}