summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-11 09:08:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-11 09:56:28 +0200
commit1ddb11a28081efc0889a23e24022f270c1181fc1 (patch)
tree173a5df6ef5b913231c1e85c48fcf8a7c4f0604f /sys-auth
parentdev-python/sqlalchemy: Bump to 1.4.15 (diff)
downloadgentoo-1ddb11a28081efc0889a23e24022f270c1181fc1.tar.gz
gentoo-1ddb11a28081efc0889a23e24022f270c1181fc1.tar.bz2
gentoo-1ddb11a28081efc0889a23e24022f270c1181fc1.zip
sys-auth/nss-mdns: Bump to 0.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/nss-mdns/Manifest1
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.15.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-auth/nss-mdns/Manifest b/sys-auth/nss-mdns/Manifest
index 349b16521558..12f39cf56983 100644
--- a/sys-auth/nss-mdns/Manifest
+++ b/sys-auth/nss-mdns/Manifest
@@ -1 +1,2 @@
DIST nss-mdns-0.14.1.tar.gz 369978 BLAKE2B d1539ff5c1830a120d6ed4fafa36aa6effb9bb973b275317f5d8f4515aad7d2f69f095296a6b95ad8cc19d6eeb076b19b7987c5eabf29fd21f54cfe4a652ed3a SHA512 7c06b984443881a6c0a1f850ee33f14780562cc6168fe1cda176303eb799ece510d51d3830928616723bb95250ad6462978cd8b857f2b79d87116da2c1aeaa5e
+DIST nss-mdns-0.15.tar.gz 374714 BLAKE2B a85051604bb7ae7661e6f1d08a99327363a4101641f1441d04388c09e67b651f5721ddac592676bd993314835c8da91bb1f8df52ec0cc1545926df433f490595 SHA512 e71b625a1ac9c36cb3db71e599b89b7ac237250cd9c99ae2e392c8fc1309eb7ba2d2c32f0695eb0b7bb993142a8803065de152cf002bea967e9c263aacd4b7ac
diff --git a/sys-auth/nss-mdns/nss-mdns-0.15.ebuild b/sys-auth/nss-mdns/nss-mdns-0.15.ebuild
new file mode 100644
index 000000000000..3f730ac134f6
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.15.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="https://github.com/lathiat/nss-mdns"
+SRC_URI="https://github.com/lathiat/nss-mdns/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=net-dns/avahi-0.6.31-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-libs/check-0.11[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ local myconf=(
+ # $(localstatedir)/run/... is used to locate avahi-daemon socket
+ --localstatedir=/var
+
+ $(use_enable test tests)
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ dodoc *.md
+
+ insinto /etc
+ doins "${FILESDIR}"/mdns.allow
+}
+
+pkg_postinst() {
+ ewarn "You have to modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns. Keep in mind that mdns will be slower if there are no"
+ ewarn "IPv6 addresses published via mDNS on the network. There are also"
+ ewarn "minimal (mdns?_minimal) libraries which only lookup .local hosts"
+ ewarn "and 169.254.x.x addresses."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf."
+ ewarn "An example line looks like:"
+ ewarn "hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4"
+ ewarn
+ ewarn "If you want to perform mDNS lookups for domains other than the ones"
+ ewarn "ending in .local, add them to /etc/mdns.allow."
+}