summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-14 01:17:42 +0100
committerSam James <sam@gentoo.org>2023-05-14 01:31:21 +0100
commit307919c9a5dbf4b9ef011273d4ddf642b39b94f4 (patch)
tree8cdb50e59376f7809edebf07cb96d399140d0a0e /sys-auth
parentnet-misc/wget2: drop invalid USE=valgrind flag (for test suite) (diff)
downloadgentoo-307919c9a5dbf4b9ef011273d4ddf642b39b94f4.tar.gz
gentoo-307919c9a5dbf4b9ef011273d4ddf642b39b94f4.tar.bz2
gentoo-307919c9a5dbf4b9ef011273d4ddf642b39b94f4.zip
sys-auth/sssd: drop invalid USE=valgrind flag (for test suite)
We don't, in general, run Valgrind for test suites in Gentoo because it's not portable enough and gives inconsistent results, especially under sandbox. Plus it's confusing given USE=valgrind is effectively a global USE flag (even if it isn't in use.desc yet) for meaning "enable annotations to enable better debugging under Valgrind", rather than "run tests under it". Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/sssd/metadata.xml1
-rw-r--r--sys-auth/sssd/sssd-2.5.2-r3.ebuild9
-rw-r--r--sys-auth/sssd/sssd-2.6.0-r2.ebuild9
3 files changed, 8 insertions, 11 deletions
diff --git a/sys-auth/sssd/metadata.xml b/sys-auth/sssd/metadata.xml
index 5c228f8abb75..36a8e6c631a2 100644
--- a/sys-auth/sssd/metadata.xml
+++ b/sys-auth/sssd/metadata.xml
@@ -13,7 +13,6 @@
<flag name="pac">Add Privileged Attribute Certificate Support for Kerberos</flag>
<flag name="sudo">Build helper to let <pkg>app-admin/sudo</pkg> use sssd provided information</flag>
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
- <flag name="valgrind">Depend on <pkg>dev-util/valgrind</pkg> for test suite</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:fedoraproject:sssd</remote-id>
diff --git a/sys-auth/sssd/sssd-2.5.2-r3.ebuild b/sys-auth/sssd/sssd-2.5.2-r3.ebuild
index fc6be18d464f..c74bc5252e9e 100644
--- a/sys-auth/sssd/sssd-2.5.2-r3.ebuild
+++ b/sys-auth/sssd/sssd-2.5.2-r3.ebuild
@@ -15,13 +15,12 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-CVE-2021
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="acl doc +locator +netlink nfsv4 nls +man pac python samba selinux sudo systemd systemtap test valgrind"
+IUSE="acl doc +locator +netlink nfsv4 nls +man pac python samba selinux sudo systemd systemtap test"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
pac? ( samba )
- test? ( sudo )
- valgrind? ( test )"
+ test? ( sudo )"
BDEPEND=">=sys-devel/autoconf-2.69-r5
virtual/pkgconfig
@@ -36,7 +35,6 @@ BDEPEND=">=sys-devel/autoconf-2.69-r5
sys-libs/nss_wrapper
sys-libs/pam_wrapper
sys-libs/uid_wrapper
- valgrind? ( dev-util/valgrind )
)
man? (
app-text/docbook-xml-dtd:4.4
@@ -158,6 +156,8 @@ multilib_src_configure() {
--with-unicode-lib="glib2"
--disable-rpath
--disable-static
+ # Valgrind is only used for tests
+ --disable-valgrind
--sbindir=/usr/sbin
--enable-local-provider
$(multilib_native_use_with systemd kcm)
@@ -177,7 +177,6 @@ multilib_src_configure() {
$(multilib_native_with autofs)
$(multilib_native_with ssh)
$(use_enable systemtap)
- $(use_enable valgrind)
--without-python2-bindings
$(multilib_native_use_with python python3-bindings)
)
diff --git a/sys-auth/sssd/sssd-2.6.0-r2.ebuild b/sys-auth/sssd/sssd-2.6.0-r2.ebuild
index 7d4de9b612d8..ed2f740d4b06 100644
--- a/sys-auth/sssd/sssd-2.6.0-r2.ebuild
+++ b/sys-auth/sssd/sssd-2.6.0-r2.ebuild
@@ -14,12 +14,11 @@ SRC_URI="https://github.com/SSSD/sssd/releases/download/${PV}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc x86"
-IUSE="acl doc +locator +netlink nfsv4 nls +man pac python samba selinux sudo systemd systemtap test valgrind"
+IUSE="acl doc +locator +netlink nfsv4 nls +man pac python samba selinux sudo systemd systemtap test"
REQUIRED_USE="
pac? ( samba )
python? ( ${PYTHON_REQUIRED_USE} )
- test? ( sudo )
- valgrind? ( test )"
+ test? ( sudo )"
RESTRICT="!test? ( test )"
DEPEND="
@@ -75,7 +74,6 @@ BDEPEND="
sys-libs/nss_wrapper
sys-libs/pam_wrapper
sys-libs/uid_wrapper
- valgrind? ( dev-util/valgrind )
)
man? (
app-text/docbook-xml-dtd:4.4
@@ -148,6 +146,8 @@ multilib_src_configure() {
--with-os=gentoo
--disable-rpath
--disable-static
+ # Valgrind is only used for tests
+ --disable-valgrind
--sbindir="${EPREFIX}"/usr/sbin
$(multilib_native_use_with systemd kcm)
$(use_with samba)
@@ -165,7 +165,6 @@ multilib_src_configure() {
$(multilib_native_with autofs)
$(multilib_native_with ssh)
$(use_enable systemtap)
- $(use_enable valgrind)
--without-python2-bindings
$(multilib_native_use_with python python3-bindings)
# Annoyingly configure requires that you pick systemd XOR sysv