summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-06-06 00:22:26 +0800
committerJason Zaman <perfinion@gentoo.org>2017-06-06 01:46:09 +0800
commit874b64c01644050dc7d017145d61221c28539aa8 (patch)
tree92bc9033fc0bf75a3a3faf7c7c488aab14695657 /sys-auth
parentdev-python/whelk: Add tests, add python3_{5,6} (diff)
downloadgentoo-874b64c01644050dc7d017145d61221c28539aa8.tar.gz
gentoo-874b64c01644050dc7d017145d61221c28539aa8.tar.bz2
gentoo-874b64c01644050dc7d017145d61221c28539aa8.zip
sys-auth/consolekit: bump to 1.1.2 (bug 620894)
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/Manifest1
-rw-r--r--sys-auth/consolekit/consolekit-1.1.2.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/sys-auth/consolekit/Manifest b/sys-auth/consolekit/Manifest
index 9e317be2c9da..d60cbef55988 100644
--- a/sys-auth/consolekit/Manifest
+++ b/sys-auth/consolekit/Manifest
@@ -2,4 +2,5 @@ DIST ConsoleKit-0.4.6.tar.xz 366572 SHA256 b41d17e06f80059589fbeefe96ad07bcc564c
DIST ConsoleKit2-1.0.1.tar.bz2 1192681 SHA256 741c53321a0792b165f386c73c668af25615accab6d15983290103348a3ff00c SHA512 028e7347ff7293ebf3d08541d801e987cbc82fb31d98b67aa23e6dc28d00a422db9591c716c568320b6dde3fa01eb0b77b43c06d230f4bedd1085e078848a202 WHIRLPOOL c555281cd177ed243b1beb3d07d2988d029d8d89cac5242d12dcc37270d2d7adb1d503eaeba2f466964b589c4d10b8f2f014fef7067b535a7be9a360612d0485
DIST ConsoleKit2-1.1.0.tar.bz2 630178 SHA256 a40d92358aca9f627a224dca674090e310423b00ed63fc06482997611661b69b SHA512 14ded07d4140e7a31132de21e84c2878475676b8c98f72b42340708972ed384abb9ba9380d74719718fc220c001387c788cf709cd15f8b19d598467dfe8a57df WHIRLPOOL 8f08d81576b5121b2da6cd94b3b5675ea55dce17997b035d0ba451c011b101f9e315e983b20610ee022ee286b50a7b13e2508584b9c08dba0c6cda20b8801a63
DIST ConsoleKit2-1.1.1.tar.bz2 1372801 SHA256 795b2cfb766bdffb9187ef7f8beb8d8298e4c38df4a69377115297a0dee3b0d0 SHA512 168af9760e10914dff5e693d2c3b2e2a35b1662fc2769e2954eec0238f7f313ff154add650fa6f0f59e73e4e0aec2fe63ff62446a3c73c2d4437408e69aa97b6 WHIRLPOOL cef8ac778923671f9bffe87ecd8045b30630578e2599d0ccf37ad8d8070b7c0ca6936e9837abc5fc1f7af5f119edfeae68d9a14199485936677a5faba09b0958
+DIST ConsoleKit2-1.1.2.tar.bz2 1125567 SHA256 f4b26b45edf7416ed76052b8f85ea05b7b560c744edee8042575667528bc1f24 SHA512 fadca85e05c176b06ead40fba5c068d497bf69bcc322287363d0c27cdd6627b758295db1ef534b908c0e6240486430d8cb36660b4d71216a60d19a52d6d0db39 WHIRLPOOL b9655418498cb2b63a30d6d1a56f6afe0adf8f6ae3a6aa97fc55da8288fae588deea04ab868f0ef524e185696ad87a35aca6de8eb4e6cb32bc4ba729040e0cbb
DIST consolekit_0.4.6-4.debian.tar.gz 12192 SHA256 6d4dd5e13a76454b4bab27ab6b407718cd77616afd2b1af7cb8d947c1323b802 SHA512 f7fc5965b1f495d16a8ca167940431bc2569e9bde9e4a356b9c9ed00c2825db61da7b6db3d434d977fff72b3aaef30c455a365b9eba282a887a523753613b58f WHIRLPOOL 961a918c21259e24c68c7a5bf93964825b891ea207c088fecab61f81434012dc8925fca83b74518cfc9cf42f2c4a87eba7518c0829f663716ca0e11e38c856c9
diff --git a/sys-auth/consolekit/consolekit-1.1.2.ebuild b/sys-auth/consolekit/consolekit-1.1.2.ebuild
new file mode 100644
index 000000000000..0ff201ad989b
--- /dev/null
+++ b/sys-auth/consolekit/consolekit-1.1.2.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools libtool linux-info pam
+
+MY_PN=ConsoleKit2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Framework for defining and tracking users, login sessions and seats"
+HOMEPAGE="https://github.com/ConsoleKit2/ConsoleKit2 https://www.freedesktop.org/wiki/Software/ConsoleKit"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/releases/download/${PV}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="acl cgroups debug doc evdev kernel_linux pam pm-utils policykit selinux test udev"
+
+COMMON_DEPEND=">=dev-libs/glib-2.40:2=[dbus]
+ >=sys-devel/gettext-0.19
+ sys-apps/dbus
+ sys-libs/zlib:=
+ x11-libs/libX11:=
+ acl? (
+ sys-apps/acl:=
+ >=virtual/udev-200
+ )
+ cgroups? (
+ app-admin/cgmanager
+ >=sys-libs/libnih-1.0.2[dbus]
+ )
+ evdev? ( dev-libs/libevdev:= )
+ udev? (
+ virtual/libudev
+ x11-libs/libdrm:=
+ )
+ pam? ( virtual/pam )
+ policykit? ( >=sys-auth/polkit-0.110 )
+ selinux? ( sys-libs/libselinux )"
+# pm-utils: bug 557432
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/coreutils[acl?] )
+ pm-utils? ( sys-power/pm-utils )
+ selinux? ( sec-policy/selinux-consolekit )"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xmlto )
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+QA_MULTILIB_PATHS="usr/lib/ConsoleKit/.*"
+
+pkg_setup() {
+ if use kernel_linux; then
+ # This is from https://bugs.gentoo.org/376939
+ use acl && CONFIG_CHECK="~TMPFS_POSIX_ACL"
+ # This is required to get login-session-id string with pam_ck_connector.so
+ use pam && CONFIG_CHECK+=" ~AUDITSYSCALL"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
+
+ default
+ # patch needs autoreconf, so dont need libtoolize
+ eautoreconf
+ #elibtoolize # bug 593314
+}
+
+src_configure() {
+ econf \
+ XMLTO_FLAGS='--skip-validation' \
+ --libexecdir="${EPREFIX}"/usr/lib/ConsoleKit \
+ --localstatedir="${EPREFIX}"/var \
+ $(use_enable pam pam-module) \
+ $(use_enable doc docbook-docs) \
+ $(use_enable test docbook-docs) \
+ $(use_enable debug) \
+ $(use_enable policykit polkit) \
+ $(use_enable evdev libevdev) \
+ $(use_enable acl udev-acl) \
+ $(use_enable cgroups libcgmanager) \
+ $(use_enable selinux libselinux) \
+ $(use_enable udev libudev) \
+ $(use_enable test tests) \
+ --with-dbus-services="${EPREFIX}"/usr/share/dbus-1/services \
+ --with-pam-module-dir="$(getpam_mod_dir)" \
+ --with-xinitrc-dir="${EPREFIX}"/etc/X11/xinit/xinitrc.d \
+ --without-systemdsystemunitdir
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ htmldocdir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ install
+
+ dosym /usr/lib/ConsoleKit /usr/lib/${PN}
+
+ dodoc AUTHORS HACKING NEWS README TODO
+
+ newinitd "${FILESDIR}"/${PN}-1.0.0.initd consolekit
+
+ keepdir /usr/lib/ConsoleKit/run-seat.d
+ keepdir /usr/lib/ConsoleKit/run-session.d
+ keepdir /etc/ConsoleKit/run-session.d
+ keepdir /var/log/ConsoleKit
+
+ exeinto /etc/X11/xinit/xinitrc.d
+ newexe "${FILESDIR}"/90-consolekit-3 90-consolekit
+
+ if use kernel_linux; then
+ # bug 571524
+ exeinto /usr/lib/ConsoleKit/run-session.d
+ doexe "${FILESDIR}"/pam-foreground-compat.ck
+ fi
+
+ prune_libtool_files --all # --all for pam_ck_connector.la
+
+ rm -rf "${ED}"/var/run || die # let the init script create the directory
+}