summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-20 13:12:31 -0400
committerMike Gilbert <floppym@gentoo.org>2021-10-20 13:12:31 -0400
commit8a19f6df4d067ee0d4b181ff3b90d006c1abbfeb (patch)
tree7d7871f992e43791a3760342e9a037046474f51f /sys-auth
parentapp-crypt/stoken: fix automagic dep on libtomcrypt (diff)
downloadgentoo-8a19f6df4d067ee0d4b181ff3b90d006c1abbfeb.tar.gz
gentoo-8a19f6df4d067ee0d4b181ff3b90d006c1abbfeb.tar.bz2
gentoo-8a19f6df4d067ee0d4b181ff3b90d006c1abbfeb.zip
sys-auth/oath-toolkit: add static-libs USE flag
Also drop *.la. Closes: https://bugs.gentoo.org/725686 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild (renamed from sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild)6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild
index 6e5a98f59d54..e6e4f650cf44 100644
--- a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.2-r1.ebuild
@@ -11,7 +11,7 @@ LICENSE="GPL-3 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86"
-IUSE="pam pskc test"
+IUSE="pam pskc static-libs test"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -53,11 +53,13 @@ src_configure() {
$(use_enable test xmltest ) \
$(use_enable pam) \
$(use_with pam pam-dir $(getpam_mod_dir)) \
- $(use_enable pskc)
+ $(use_enable pskc) \
+ $(use_enable static-libs static)
}
src_install() {
default
+ find "${ED}" -name '*.la' -type f -delete || die
if use pam; then
newdoc pam_oath/README README.pam
fi