summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2021-10-20 14:15:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-23 16:00:12 +0300
commit96cb15f52b9304ce184b5fb76a3afbf3144e106a (patch)
treea6ec9cf75ef311b328aba5909743b1ac143cd4d0 /sys-auth
parentsys-auth/seatd: Apply seat group fix on live ebuild (diff)
downloadgentoo-96cb15f52b9304ce184b5fb76a3afbf3144e106a.tar.gz
gentoo-96cb15f52b9304ce184b5fb76a3afbf3144e106a.tar.bz2
gentoo-96cb15f52b9304ce184b5fb76a3afbf3144e106a.zip
sys-auth/seatd: Version bump, 0.6.3
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me> Closes: https://github.com/gentoo/gentoo/pull/22682 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/seatd/Manifest1
-rw-r--r--sys-auth/seatd/seatd-0.6.3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-auth/seatd/Manifest b/sys-auth/seatd/Manifest
index 1ca089176645..5cd5acd8009f 100644
--- a/sys-auth/seatd/Manifest
+++ b/sys-auth/seatd/Manifest
@@ -1,2 +1,3 @@
DIST seatd-0.5.0.tar.gz 34762 BLAKE2B 054bd64800b734f6092f856540217e5ea4872c5a363960bac6c5aa7dac5355bdbd982232efd2f8078ad326ec0e6257f3ee7643384c88a3bbe15255d65f02540c SHA512 a6b1f11313411fe99e8bdd64aa493fc19bde7b0b927f21e2c3ec8a7fadc6cf2f04fcefa73fa033d971d1dc482665d3dc927ec168026289fe88b2593a45adbc0f
DIST seatd-0.6.2.tar.gz 37713 BLAKE2B 001c6269bcc83488099f9237a3412b61f89cf653fcb5b0d1ada3f5fbdb17ec604d881ce3d835ff1ea3bc683bb143bab75de88d67b55f508e6a9dd2e958347567 SHA512 47e3aec819f43e72913be1cac2c0db26287f1ef8ecc738845d3591b3e2b4fee3441ac50ea45ac75a5da774e5305a18a02b8375f76f71644c8c07e95bcad52762
+DIST seatd-0.6.3.tar.gz 38525 BLAKE2B e1bdb85f9432a9a407ea7a72ed5790debf01a410546e9162641ab55179b3beefba0eb45fd24e2643dc5cfb2a26db2490f49095ff1d08b4a38663f93e46dc2ed5 SHA512 28c979e8c2fc73a8607c6085f2e27dc6e2630bc874f98686ce22aa797e74fdad1cc9fca8649eaf8920e93f01a852fbe209bde86ebf582e81060d4ca015425815
diff --git a/sys-auth/seatd/seatd-0.6.3.ebuild b/sys-auth/seatd/seatd-0.6.3.ebuild
new file mode 100644
index 000000000000..2c8b264374b9
--- /dev/null
+++ b/sys-auth/seatd/seatd-0.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson systemd
+
+DESCRIPTION="Minimal seat management daemon and universal library"
+HOMEPAGE="https://sr.ht/~kennylevinsen/seatd"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~kennylevinsen/seatd"
+else
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+ SRC_URI="https://git.sr.ht/~kennylevinsen/seatd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+LICENSE="MIT"
+SLOT="0/1"
+IUSE="builtin elogind +server systemd"
+REQUIRED_USE="?? ( elogind systemd )"
+
+DEPEND="
+ elogind? ( sys-auth/elogind )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ server? ( acct-group/seat )
+"
+BDEPEND=">=app-text/scdoc-1.9.7"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=enabled
+ -Dwerror=false
+ $(meson_feature builtin libseat-builtin)
+ $(meson_feature server)
+ )
+
+ if use elogind ; then
+ emesonargs+=( -Dlibseat-logind=elogind )
+ elif use systemd; then
+ emesonargs+=( -Dlibseat-logind=systemd )
+ else
+ emesonargs+=( -Dlibseat-logind=disabled )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if use server; then
+ newinitd "${FILESDIR}/seatd.initd" seatd
+ systemd_dounit contrib/systemd/seatd.service
+ fi
+}