summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-01-14 03:38:43 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-01-14 03:38:43 +0100
commit9e4a06be33045f5d1325ff7c95a4dfd150d70607 (patch)
treeae3cf1fe75b88b972d48f5d991915e9b4096760b /sys-auth
parentapp-dicts/aspell-pl: add 6.0.20240101.0 (diff)
downloadgentoo-9e4a06be33045f5d1325ff7c95a4dfd150d70607.tar.gz
gentoo-9e4a06be33045f5d1325ff7c95a4dfd150d70607.tar.bz2
gentoo-9e4a06be33045f5d1325ff7c95a4dfd150d70607.zip
sys-auth/AusweisApp2: add 2.0.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild47
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild b/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-2.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 37061fb99ac7..b54f3210892a 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-2.0.1.tar.gz 9123033 BLAKE2B 86f0d9838285bc35a29611e14c4328c584ffeff5c584916960486f9b120ff7472372fdb250a7a014ecfd2e3fdf4992fb827387c6e374427ef0b178f6f455cdf7 SHA512 81ceeab73111cce3f72a89584dedd78436190fca47d6901eb7d9a15775df06ce0dac12ff3cc52c38c82cd316d50ffaae6b2d7a8c85d9fb7e6ead58850b5ea535
+DIST AusweisApp2-2.0.2.tar.gz 9125599 BLAKE2B 3f48007d330be35bebb49f668a01cc765225bfb2ccc9dfa01f32dc1fe3905077a5bcc9c08a8b01fac8df713571b539b358aacbb1e96dad7715fb64d0312a5252 SHA512 9433199b1d1f8f53a0c95b6c1b4f05ed0cf58f6a7afee35618f2cf8a45d2212584bf2bffad4e850e0413cfaa9a3223c3495fad6165581fa3933630eb249aa104