summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-12-20 22:51:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-12-20 23:03:20 +0100
commitc12cb33ed6349cd86062faf2eb0119f20594de74 (patch)
treec686f7276b7b95291704d16fce7e70091ddd6d04 /sys-auth
parentdev-lua/luacheck: fix UnusedInherits (diff)
downloadgentoo-c12cb33ed6349cd86062faf2eb0119f20594de74.tar.gz
gentoo-c12cb33ed6349cd86062faf2eb0119f20594de74.tar.bz2
gentoo-c12cb33ed6349cd86062faf2eb0119f20594de74.zip
sys-auth/AusweisApp2: add 1.26.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.26.1.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.26.1.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.26.1.ebuild
new file mode 100644
index 000000000000..f1b6cc8c799f
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.26.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index bdc6598b21a2..c6adf386fa02 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.24.4.tar.gz 11482381 BLAKE2B 26bb34bcefbe4dfce4b30300e71fdab61afa3a30c4b17dd5d90abc4f0cbaca062f7d91f0d49a082a3436a43b3a880f3771e879774f22e35963a905485c8e3c7e SHA512 672b1e7a4543824afa241430b6784eef38273f32436451270c84d02617044b727691e3e15aa2ac09a06d3286a36e81c54c205f706a3db6c5cfabc48cf0a52c30
+DIST AusweisApp2-1.26.1.tar.gz 11488062 BLAKE2B a46dfc13bcbc6b6594732ff22bc41a35c587f659cea32e9c339dad9042c92ebf3c1591bd4b2c41ebed34c231b50d9aca1344e863de405af0ce54c5159b6d7c6f SHA512 ffad0d735adf963c3f4df054bd113f15d2dc0da59b77a91af676b5646f779dcc0d1d3a313d3a666dc406401cd154215ac7462ed0ecf97df69b8da19f799cdaf3