summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-06-12 22:49:42 +0800
committerJason Zaman <perfinion@gentoo.org>2017-06-13 23:10:26 +0800
commite72fcb2fc9ed567137b78ff738f5d11b540ecaba (patch)
treecdd9c5f0dfe9ef7fc31bdf5a690fbe20f0711733 /sys-auth
parentdev-db/myodbc: Add binary based ebuild from upstream (diff)
downloadgentoo-e72fcb2fc9ed567137b78ff738f5d11b540ecaba.tar.gz
gentoo-e72fcb2fc9ed567137b78ff738f5d11b540ecaba.tar.bz2
gentoo-e72fcb2fc9ed567137b78ff738f5d11b540ecaba.zip
sys-auth/consolekit: reset xdg environment (bug 621040)
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/consolekit/consolekit-1.1.2.ebuild4
-rw-r--r--sys-auth/consolekit/consolekit-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-auth/consolekit/consolekit-1.1.2.ebuild b/sys-auth/consolekit/consolekit-1.1.2.ebuild
index 0ff201ad989b..94b183899d1a 100644
--- a/sys-auth/consolekit/consolekit-1.1.2.ebuild
+++ b/sys-auth/consolekit/consolekit-1.1.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools libtool linux-info pam
+inherit autotools libtool linux-info pam xdg-utils
MY_PN=ConsoleKit2
MY_P=${MY_PN}-${PV}
@@ -66,6 +66,8 @@ pkg_setup() {
}
src_prepare() {
+ xdg_environment_reset
+
sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
default
diff --git a/sys-auth/consolekit/consolekit-9999.ebuild b/sys-auth/consolekit/consolekit-9999.ebuild
index 602bd0d11b8a..a87eea41cc33 100644
--- a/sys-auth/consolekit/consolekit-9999.ebuild
+++ b/sys-auth/consolekit/consolekit-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools libtool git-r3 linux-info pam
+inherit autotools libtool git-r3 linux-info pam xdg-utils
MY_PN=ConsoleKit2
MY_P=${MY_PN}-${PV}
@@ -64,6 +64,8 @@ pkg_setup() {
}
src_prepare() {
+ xdg_environment_reset
+
sed -i -e '/SystemdService/d' data/org.freedesktop.ConsoleKit.service.in || die
default