summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2023-03-12 19:42:26 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-03-12 19:59:56 +0100
commiteb78d707790b690f87b8ce5423cf829fe5017010 (patch)
tree8f6f29a869b57a6c7521b1a55224dc344a18c1a3 /sys-auth
parentsys-apps/cpuid: drop 20230228 (diff)
downloadgentoo-eb78d707790b690f87b8ce5423cf829fe5017010.tar.gz
gentoo-eb78d707790b690f87b8ce5423cf829fe5017010.tar.bz2
gentoo-eb78d707790b690f87b8ce5423cf829fe5017010.zip
sys-auth/AusweisApp2: add 1.26.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.26.3.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.26.3.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.26.3.ebuild
new file mode 100644
index 000000000000..e5e3ddda4634
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.26.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 58e31c9a905a..8d3b93a52a59 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1 +1,2 @@
DIST AusweisApp2-1.26.2.tar.gz 11491524 BLAKE2B dc73b9e62d3b50c5a904303f61a6ce6bfce6ab8795f0989a943c238e889f8d60bd27db2a403cf98aada4875253a58a5de46be415c0da0e201b292aca102a675d SHA512 8a133ad64ff7910852069b70250abb476fbb4a9f68f08efb9c5fb882bfa3328671e81b185a3ea7d3b936694057bc31cedaeb99cdfe07e3da79ea0474607b1273
+DIST AusweisApp2-1.26.3.tar.gz 10842706 BLAKE2B b18fdc67a24cca5be866ce3f2d59133732a8086d3f5711ac81783e66010e1590e9e06106ff60b6fb20910060610e483a924169e67f51feb2c82ec876761e7a2e SHA512 67fb6653a15df0c6182953e5bad19513d29b1ca90699e4f32145ded7f2a157ef2f0e98f00392548ba680fc9b08a95c6b4a9d6bd23fed6f1a000a2ac1de4ff52b