summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 17:39:00 +0100
committerSam James <sam@gentoo.org>2023-06-26 17:47:19 +0100
commitfb16875ad4849a04406ebd52808c93db2acf906f (patch)
treeb65c2578414c88b1569d86729fc99b214c317e59 /sys-auth
parentmedia-video/pipewire: add 0.3.72 (diff)
downloadgentoo-fb16875ad4849a04406ebd52808c93db2acf906f.tar.gz
gentoo-fb16875ad4849a04406ebd52808c93db2acf906f.tar.bz2
gentoo-fb16875ad4849a04406ebd52808c93db2acf906f.zip
sys-auth/passwdqc: add 2.0.3
This changes the default to enforce=none as it's repeatedly caused confusion for users and they often find it quite frustrating. People are free to set stricter options if they want. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/passwdqc/Manifest1
-rw-r--r--sys-auth/passwdqc/passwdqc-2.0.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-auth/passwdqc/Manifest b/sys-auth/passwdqc/Manifest
index 30e6dfcd0b53..48eb4b6d7b16 100644
--- a/sys-auth/passwdqc/Manifest
+++ b/sys-auth/passwdqc/Manifest
@@ -1,2 +1,3 @@
DIST passwdqc-1.4.0.tar.gz 55219 BLAKE2B 3f96a2d219ee23f11db2ad8ba433eaa56b97a263ad1a49159e0356b779cb4486ec9aa74cd7002fdd6d273e5a7bae4fe1b94e02f60256d331e5afc30d63e81360 SHA512 b9be6632688a1d7d929ec546679a366a67d44e7841e106c7f739a8e0656842866125160c87b04c8e0b3189a3e85eb182aa789196f68925b2f8ec71cd6a479800
DIST passwdqc-2.0.2.tar.gz 88796 BLAKE2B 4be0180dbee38d124cc5fd3780fcc27b276bd9370c59c83a9c037b67f18518873bd34d23f779125ac0b5e8bb1f40a5e8e24dc65bfe5919f735f96d4f625cebdb SHA512 60f91ad7c86314b0d9ad97a2474a1a5bbb8b41491b274e09f7300d8a609cfffb0688bf39d4e715f647f3c87bfee429cb5e01f1a641a14eea3f55b223610ed8ec
+DIST passwdqc-2.0.3.tar.gz 89608 BLAKE2B d4d999f1da011041e947fcf40b28977c825e7be2a9edfe641205f433862607e958d74b6e11ef5222e9791985a55dc3117c71d47b9516c521bb64ff4cddee77d5 SHA512 08a1ee0e7efe0be8af8b253147836c479247a849baf598a1ad573a050ef4b8700fdb725fd887877f82f9207f3654f489f71267cc4051ce8ebf2405125b77b6b9
diff --git a/sys-auth/passwdqc/passwdqc-2.0.3.ebuild b/sys-auth/passwdqc/passwdqc-2.0.3.ebuild
new file mode 100644
index 000000000000..f1346100a726
--- /dev/null
+++ b/sys-auth/passwdqc/passwdqc-2.0.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit pam toolchain-funcs
+
+DESCRIPTION="Password strength checking library (and PAM module)"
+HOMEPAGE="http://www.openwall.com/passwdqc/"
+SRC_URI="http://www.openwall.com/${PN}/${P}.tar.gz"
+
+LICENSE="Openwall BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-libs/pam
+ virtual/libcrypt:=
+"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED="
+ lib*/security/pam_passwdqc.so
+ usr/lib*/libpasswdqc.so.1
+"
+
+src_prepare() {
+ default
+
+ sed -i -e 's:`uname -s`:Linux:' Makefile || die
+
+ # Ship our own default settings
+ cat <<- EOF > "${S}/passwdqc.conf"
+ min=disabled,24,11,8,7
+ max=72
+ passphrase=3
+ match=4
+ similar=deny
+ random=47
+ enforce=none
+ retry=3
+ EOF
+
+}
+
+_emake() {
+ emake \
+ SHARED_LIBDIR="/usr/$(get_libdir)" \
+ SECUREDIR="$(getpam_mod_dir)" \
+ CONFDIR="/etc/security" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake all
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" install_lib install_pam install_utils
+ dodoc README PLATFORMS INTERNALS
+}