summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-21 11:40:45 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-21 11:40:45 +0200
commitfc9ddabfcc5fa9967e0e21ed68d25db15f53e06f (patch)
treef6f0c08574f5f499cde0688f004bfb7fc5d6290b /sys-auth
parentsys-apps/smartmontools: drop 7.2-r2 (diff)
downloadgentoo-fc9ddabfcc5fa9967e0e21ed68d25db15f53e06f.tar.gz
gentoo-fc9ddabfcc5fa9967e0e21ed68d25db15f53e06f.tar.bz2
gentoo-fc9ddabfcc5fa9967e0e21ed68d25db15f53e06f.zip
sys-auth/ssh-ldap-pubkey: drop 1.3.3
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/ssh-ldap-pubkey/Manifest1
-rw-r--r--sys-auth/ssh-ldap-pubkey/files/ssh-ldap-pubkey-1.3.3-python3.9.patch34
-rw-r--r--sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.3.ebuild73
3 files changed, 0 insertions, 108 deletions
diff --git a/sys-auth/ssh-ldap-pubkey/Manifest b/sys-auth/ssh-ldap-pubkey/Manifest
index fcc55b832db2..4a42d309fcbe 100644
--- a/sys-auth/ssh-ldap-pubkey/Manifest
+++ b/sys-auth/ssh-ldap-pubkey/Manifest
@@ -1,2 +1 @@
-DIST ssh-ldap-pubkey-1.3.3.tar.gz 15389 BLAKE2B 24c741646e33cf7af400053eff17efa35b96ec418d1c2b8c370a371dde51fdbbb3af3423f0cc4374f61b302f9836601444ee72613388fa2d4445957f918d64f9 SHA512 b52d4de3e0704817e8ea0fb316c21646da1bac74ed226812c03f9ee5ae449a86e5ef4c679633d212db05382e216b254a185e29d4a2244318ad5de288b909254a
DIST ssh-ldap-pubkey-1.4.0.tar.gz 15461 BLAKE2B 8e78fd6a5fa76ca97e813c95c9cbfefc3d40024cb31b8992de0c44770592f5abc7d8f0a4673905456dbe9a4272c1ce9a9e12bec69d9f8fa2f32a9b7a1895b978 SHA512 a62929b47f46f18936fcc7c233afaee43f0cef5f7a8de15304986205f98c2644a18f9c0dcabb35598f1cc485b8c4dbeb8b2f07cb2c3dcbb6b271a276aebf88e7
diff --git a/sys-auth/ssh-ldap-pubkey/files/ssh-ldap-pubkey-1.3.3-python3.9.patch b/sys-auth/ssh-ldap-pubkey/files/ssh-ldap-pubkey-1.3.3-python3.9.patch
deleted file mode 100644
index b646603a134a..000000000000
--- a/sys-auth/ssh-ldap-pubkey/files/ssh-ldap-pubkey-1.3.3-python3.9.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-commit 56b4b77bfa2b063b3f3686b54d8e39f6bce1d2a0
-Author: Thomas Deutschmann <whissi@whissi.de>
-AuthorDate: Wed Jun 2 17:40:06 2021 +0200
-Commit: Thomas Deutschmann <whissi@whissi.de>
-CommitDate: Wed Jun 2 18:01:16 2021 +0200
-
- Use decodebytes instead of decodestring in Python 3.9
-
- base64.decodestring(), alias deprecated since Python 3.1, has been removed
- in Python 3.9 in favor of new base64.decodebytes() function [Link 1].
-
- Link 1: https://docs.python.org/3.9/whatsnew/3.9.html#removed
- Closes: https://github.com/jirutka/ssh-ldap-pubkey/issues/49
-
-diff --git a/ssh_ldap_pubkey/__init__.py b/ssh_ldap_pubkey/__init__.py
-index 5da2ade..d80b335 100644
---- a/ssh_ldap_pubkey/__init__.py
-+++ b/ssh_ldap_pubkey/__init__.py
-@@ -39,8 +39,14 @@ def is_valid_openssh_pubkey(pubkey):
- key_type, data64 = map(_encode, pubkey.split()[0:2])
- except (ValueError, AttributeError):
- return False
-+
-+ if hasattr(base64, "decodebytes"):
-+ decodebytes = base64.decodebytes
-+ else:
-+ decodebytes = base64.decodestring
-+
- try:
-- data = base64.decodestring(data64)
-+ data = decodebytes(data64)
- except base64.binascii.Error:
- return False
-
diff --git a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.3.ebuild b/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.3.ebuild
deleted file mode 100644
index ac7bd5162af7..000000000000
--- a/sys-auth/ssh-ldap-pubkey/ssh-ldap-pubkey-1.3.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-inherit distutils-r1
-
-DESCRIPTION="Utility to manage SSH public keys stored in LDAP"
-HOMEPAGE="https://github.com/jirutka/ssh-ldap-pubkey"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/jirutka/${PN}/${PN}.git"
-
- inherit git-r3
-else
- SRC_URI="https://github.com/jirutka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="schema test"
-RESTRICT="!test? ( test )"
-
-MY_CDEPEND="
- dev-python/docopt[${PYTHON_USEDEP}]
- >=dev-python/python-ldap-3.0[${PYTHON_USEDEP}]
- virtual/logger"
-
-DEPEND="
- ${MY_CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-describe[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
-
-# We need to block previous net-misc/openssh packages
-# to avoid file collision on "/etc/openldap/schema/openssh-lpk.schema"
-RDEPEND="${MY_CDEPEND}
- schema? ( !net-misc/openssh[ldap(-)] )"
-
-DOCS=( README.md CHANGELOG.adoc )
-
-PATCHES=( "${FILESDIR}"/${P}-python3.9.patch )
-
-src_prepare() {
- sed -i -e 's/pyldap/python-ldap >= 3.0/' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use schema; then
- insinto /etc/openldap/schema
- doins etc/openssh-lpk.schema
- fi
-
- local MY_DOCDIR="/usr/share/doc/${PF}/examples"
- insinto "${MY_DOCDIR}"
- doins etc/ldap.conf
-
- # We don't want to compress this small file to allow user
- # to diff configuration against upstream's default
- docompress -x "${MY_DOCDIR}"
-}