summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2021-06-14 22:49:43 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2021-06-20 10:16:30 -0700
commitfebd11c8159f476e2b0b2f150388182eca5bb6ad (patch)
treef8cea2ef2bac9b6969e2c8489560df591c7755eb /sys-block/blktrace/blktrace-1.3.0.ebuild
parentdev-libs/icu-layoutex: Drop 68.2 (diff)
downloadgentoo-febd11c8159f476e2b0b2f150388182eca5bb6ad.tar.gz
gentoo-febd11c8159f476e2b0b2f150388182eca5bb6ad.tar.bz2
gentoo-febd11c8159f476e2b0b2f150388182eca5bb6ad.zip
sys-block/blktrace: new upstream release after 4 years.
The distfile is identical to the upstream snapshot dated p20210419122502 with the exception of the incremented version number, so it takes the stable keywords as the upstream snapshot distfile will be removed from the origin SRC_URI shortly. Reference: https://bugs.gentoo.org/655146 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-block/blktrace/blktrace-1.3.0.ebuild')
-rw-r--r--sys-block/blktrace/blktrace-1.3.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-block/blktrace/blktrace-1.3.0.ebuild b/sys-block/blktrace/blktrace-1.3.0.ebuild
new file mode 100644
index 000000000000..5767d176387e
--- /dev/null
+++ b/sys-block/blktrace/blktrace-1.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs flag-o-matic linux-info
+
+MY_PN="blktrace"
+if [[ ${PV} =~ _p20 ]]; then
+ #https://brick.kernel.dk/snaps/blktrace-git-20210419122502.tar.gz
+ MY_P="${MY_PN}-git-${PV/*_p}"
+ EXT='tar.gz'
+ S="${WORKDIR}/${PN}"
+else
+ MY_P="${MY_PN}-${PV}"
+ EXT='tar.bz2'
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="show detailed info about what is happening on a block device io queue"
+HOMEPAGE="https://git.kernel.dk/cgit/blktrace/"
+SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.${EXT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/libaio"
+# This is a Linux specific app!
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? (
+ virtual/latex-base
+ >=app-text/texlive-core-2014
+ )
+"
+
+CONFIG_CHECK="~BLK_DEV_IO_TRACE"
+WARNING_BLK_DEV_IO_TRACE="you need to enable BLK_DEV_IO_TRACE kernel option if you want to gather traces from this machine"
+
+PATCHES=(
+ #"${FILESDIR}"/${P}-overlapping-io-stats.patch
+ #"${FILESDIR}"/${PN}-1.2.0-ldflags.patch #335741
+ #"${FILESDIR}"/${PN}-1.2.0-parallel-build.patch #335741
+)
+
+src_compile() {
+ append-cppflags -DLVM_REMAP_WORKAROUND -W -I"${S}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}"
+ if use doc; then
+ export VARTEXFONTS="${T}/fonts"
+ emake docs
+ fi
+}
+
+src_install() {
+ emake install CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${CPPFLAGS}" DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man"
+ einstalldocs
+ use doc && dodoc doc/blktrace.pdf btt/doc/btt.pdf
+}