summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-01-23 18:02:25 -0500
committerMike Frysinger <vapier@gentoo.org>2018-01-23 18:02:36 -0500
commite7bbdf12131702c78cdeb20ef55ecbb6796af3f0 (patch)
tree97196984cd4ea37886990c5e9c4a4e08ffbb0555 /sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
parentprofiles: sparc: unmask ruby23 in stable, bug #639476 (diff)
downloadgentoo-e7bbdf12131702c78cdeb20ef55ecbb6796af3f0.tar.gz
gentoo-e7bbdf12131702c78cdeb20ef55ecbb6796af3f0.tar.bz2
gentoo-e7bbdf12131702c78cdeb20ef55ecbb6796af3f0.zip
sys-block/blktrace: version bump to 1.2.0
Diffstat (limited to 'sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch')
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch b/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
new file mode 100644
index 000000000000..b8e2aebfff4f
--- /dev/null
+++ b/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
@@ -0,0 +1,89 @@
+http://git.kernel.dk/?p=blktrace.git;a=commit;h=d1398e339585f6750f7158c50c98861b68dddc8b
+
+From 6d8c3d7a10f62b26514a56b25a3744c5f35219a6 Mon Sep 17 00:00:00 2001
+From: "Robin H. Johnson" <robbat2@gentoo.org>
+Date: Tue, 23 Jan 2018 17:40:48 -0500
+Subject: [PATCH] respect LDFLAGS when linking programs
+
+---
+ Makefile | 10 +++++-----
+ btreplay/Makefile | 4 ++--
+ btt/Makefile | 2 +-
+ iowatcher/Makefile | 2 +-
+ 4 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index fdbded02ee0a..68de59183a73 100644
+--- a/Makefile
++++ b/Makefile
+@@ -26,19 +26,19 @@ btreplay/btreplay:
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blktrace: blktrace.o act_mask.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ verify_blkparse: verify_blkparse.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkrawverify: blkrawverify.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ blkiomon: blkiomon.o rbtree.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
+
+ $(PROGS): | depend
+
+diff --git a/btreplay/Makefile b/btreplay/Makefile
+index 2998182401e7..f574a2976ec1 100644
+--- a/btreplay/Makefile
++++ b/btreplay/Makefile
+@@ -32,10 +32,10 @@ clean: docsclean
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btrecord: btrecord.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
+
+ btreplay: btreplay.o
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ depend:
+ @$(CC) -MM $(CFLAGS) *.c 1> .depend
+diff --git a/btt/Makefile b/btt/Makefile
+index df7a3de6b3fb..32075573954c 100644
+--- a/btt/Makefile
++++ b/btt/Makefile
+@@ -38,7 +38,7 @@ clean: docsclean
+ $(CC) $(CFLAGS) -c -o $*.o $<
+
+ btt: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
+
+ ifneq ($(wildcard .depend),)
+ include .depend
+diff --git a/iowatcher/Makefile b/iowatcher/Makefile
+index e013556f3ae1..a224a0848cc8 100644
+--- a/iowatcher/Makefile
++++ b/iowatcher/Makefile
+@@ -19,7 +19,7 @@ all: $(ALL)
+ $(CC) -o $*.o -c $(ALL_CFLAGS) $<
+
+ iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
+- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
++ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
+
+ depend:
+ @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend
+--
+2.15.1
+