summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2021-07-07 19:44:25 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2021-07-07 19:44:49 -0700
commit7c25464ace1616c53d5c3f8f528c35453d8ff46e (patch)
tree23dcf569320e65d98faab706ffb32fd8126a63d5 /sys-block/blktrace/files
parentsys-kernel/gentoo-kernel: add power9 kvm patch to 5.10.48 (diff)
downloadgentoo-7c25464ace1616c53d5c3f8f528c35453d8ff46e.tar.gz
gentoo-7c25464ace1616c53d5c3f8f528c35453d8ff46e.tar.bz2
gentoo-7c25464ace1616c53d5c3f8f528c35453d8ff46e.zip
sys-block/blktrace: cleanup 1.2.0
Reference: https://bugs.gentoo.org/655146 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-block/blktrace/files')
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch89
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch68
-rw-r--r--sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch71
3 files changed, 0 insertions, 228 deletions
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch b/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
deleted file mode 100644
index b8e2aebfff4f..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-ldflags.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=d1398e339585f6750f7158c50c98861b68dddc8b
-
-From 6d8c3d7a10f62b26514a56b25a3744c5f35219a6 Mon Sep 17 00:00:00 2001
-From: "Robin H. Johnson" <robbat2@gentoo.org>
-Date: Tue, 23 Jan 2018 17:40:48 -0500
-Subject: [PATCH] respect LDFLAGS when linking programs
-
----
- Makefile | 10 +++++-----
- btreplay/Makefile | 4 ++--
- btt/Makefile | 2 +-
- iowatcher/Makefile | 2 +-
- 4 files changed, 9 insertions(+), 9 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index fdbded02ee0a..68de59183a73 100644
---- a/Makefile
-+++ b/Makefile
-@@ -26,19 +26,19 @@ btreplay/btreplay:
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- blkparse: blkparse.o blkparse_fmt.o rbtree.o act_mask.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blktrace: blktrace.o act_mask.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- verify_blkparse: verify_blkparse.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blkrawverify: blkrawverify.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- blkiomon: blkiomon.o rbtree.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS) -lrt
-
- $(PROGS): | depend
-
-diff --git a/btreplay/Makefile b/btreplay/Makefile
-index 2998182401e7..f574a2976ec1 100644
---- a/btreplay/Makefile
-+++ b/btreplay/Makefile
-@@ -32,10 +32,10 @@ clean: docsclean
- $(CC) $(CFLAGS) -c -o $*.o $<
-
- btrecord: btrecord.o
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^)
-
- btreplay: btreplay.o
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- depend:
- @$(CC) -MM $(CFLAGS) *.c 1> .depend
-diff --git a/btt/Makefile b/btt/Makefile
-index df7a3de6b3fb..32075573954c 100644
---- a/btt/Makefile
-+++ b/btt/Makefile
-@@ -38,7 +38,7 @@ clean: docsclean
- $(CC) $(CFLAGS) -c -o $*.o $<
-
- btt: $(OBJS)
-- $(CC) $(CFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) $(LIBS)
-
- ifneq ($(wildcard .depend),)
- include .depend
-diff --git a/iowatcher/Makefile b/iowatcher/Makefile
-index e013556f3ae1..a224a0848cc8 100644
---- a/iowatcher/Makefile
-+++ b/iowatcher/Makefile
-@@ -19,7 +19,7 @@ all: $(ALL)
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-
- iowatcher: blkparse.o plot.o main.o tracers.o mpstat.o fio.o
-- $(CC) $(ALL_CFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
-+ $(CC) $(ALL_CFLAGS) $(LDFLAGS) -o $@ $(filter %.o,$^) -lm -lrt
-
- depend:
- @$(CC) -MM $(ALL_CFLAGS) *.c 1> .depend
---
-2.15.1
-
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch b/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch
deleted file mode 100644
index 11c495efbc0c..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-overlapping-io-stats.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=8fc451c6b0b9a7db7c376ea6865c35321e561f00
-
-From 8fc451c6b0b9a7db7c376ea6865c35321e561f00 Mon Sep 17 00:00:00 2001
-From: Gwendal Grignou <gwendal@chromium.org>
-Date: Fri, 18 Aug 2017 15:00:22 -0700
-Subject: [PATCH] btt: Fix overlapping IO stats.
-
-Keep scanning the tree for overlapping IO otherwise Q2G and process
-traces will be incorrect.
-
-Let assume we have 2 IOs:
-
-A A+a
-|---------------------------------------|
- B B+b
- |-----------------|
-
-In the red/black tree we have:
-
- o -> [A,A+a]
- / \
- left right
- / \
- [...]o o -> [B, B+b]
-
-In the current code, if we would not be able to find [B+b] in the tree:
-B is greater than A, so we won't go left
-B+b is smaller than A+a, so we are not going right either.
-
-When we have a [X, X+x] IO to look for:
-We need to check for right when either:
- X+x >= A+a (for merged IO)
-and
- X > A (for overlapping IO)
-
-TEST=Check with a trace with overlapping IO: Q2C and Q2G are expected.
-
-Signed-off-by: Gwendal Grignou <gwendal@chromium.org>
-Signed-off-by: Jens Axboe <axboe@kernel.dk>
----
- btt/dip_rb.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/btt/dip_rb.c b/btt/dip_rb.c
-index 2aa7ffcc763b..6efef6c03b8f 100644
---- a/btt/dip_rb.c
-+++ b/btt/dip_rb.c
-@@ -57,7 +57,7 @@ struct io *rb_find_sec(struct rb_root *root, __u64 sec)
- __iop = rb_entry(n, struct io, rb_node);
- if (sec < BIT_START(__iop))
- n = n->rb_left;
-- else if (sec >= BIT_END(__iop))
-+ else if (sec > BIT_START(__iop))
- n = n->rb_right;
- else
- return __iop;
-@@ -82,7 +82,7 @@ void rb_foreach(struct rb_node *n, struct io *iop,
- }
- if (iop_s < this_s)
- rb_foreach(n->rb_left, iop, fnc, head);
-- if (this_e < iop_e)
-+ if ((this_e < iop_e) || (this_s < iop_s))
- rb_foreach(n->rb_right, iop, fnc, head);
- }
- }
---
-2.15.1
-
diff --git a/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch b/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch
deleted file mode 100644
index 129f04107fa1..000000000000
--- a/sys-block/blktrace/files/blktrace-1.2.0-parallel-build.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-http://git.kernel.dk/?p=blktrace.git;a=commit;h=519fd9a5d08d85f3d9cb4192d624fe8351e40232
-
-From 4569544261be495bdec0574d7729c85a62dabad7 Mon Sep 17 00:00:00 2001
-From: "Robin H. Johnson" <robbat2@gentoo.org>
-Date: Thu, 3 Feb 2011 03:07:06 +0000
-Subject: [PATCH] fix parallel build failures
-
-When building in parallel, the btreplay/btrecord and btreplay/btreplay
-targets cause make to kick off two jobs for `make -C btreplay` and they
-sometimes end up clobbering each other. We could fix this by making one
-a dependency of the other, but it's a bit cleaner to refactor things to
-be based on subdirs. This way changes in subdirs also get noticed:
- $ touch btreplay/*.[ch]
- $ make
- <btreplay is now correctly updated>
-
-Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-Signed-off-by: Mike Frysinger <vapier@gentoo.org>
----
- Makefile | 24 ++++++++++--------------
- 1 file changed, 10 insertions(+), 14 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 68de59183a73..5917814d0344 100644
---- a/Makefile
-+++ b/Makefile
-@@ -4,23 +4,19 @@ ALL_CFLAGS = $(CFLAGS) -D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
- PROGS = blkparse blktrace verify_blkparse blkrawverify blkiomon
- LIBS = -lpthread
- SCRIPTS = btrace
-+SUBDIRS = btreplay btt iowatcher
-
--ALL = $(PROGS) $(SCRIPTS) btt/btt btreplay/btrecord btreplay/btreplay \
-+ALL = $(PROGS) $(SCRIPTS)
-+INSTALL_ALL = $(ALL) btt/btt btreplay/btrecord btreplay/btreplay \
- btt/bno_plot.py iowatcher/iowatcher
-
--all: $(ALL)
-+all: $(ALL) $(SUBDIRS)
-
--btt/btt:
-- $(MAKE) -C btt
--
--iowatcher/iowatcher:
-- $(MAKE) -C iowatcher
--
--btreplay/btrecord:
-- $(MAKE) -C btreplay
--
--btreplay/btreplay:
-- $(MAKE) -C btreplay
-+# We always descend into subdirs because they contain their own dependency
-+# information which we don't track in this top level Makefile.
-+$(SUBDIRS):
-+ $(MAKE) -C $@
-+.PHONY: $(SUBDIRS)
-
- %.o: %.c
- $(CC) -o $*.o -c $(ALL_CFLAGS) $<
-@@ -85,7 +81,7 @@ install: all
- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man8
-- $(INSTALL) -m 755 $(ALL) $(DESTDIR)$(bindir)
-+ $(INSTALL) -m 755 $(INSTALL_ALL) $(DESTDIR)$(bindir)
- $(INSTALL) -m 644 doc/*.1 $(DESTDIR)$(mandir)/man1
- $(INSTALL) -m 644 doc/*.8 $(DESTDIR)$(mandir)/man8
-
---
-2.15.1
-