summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-01-25 11:41:36 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-01-25 11:41:36 +0100
commit43358515d3e4cc74fce6de0ef44cc615b60fd6b1 (patch)
tree003648863127bf49d39608ab5e07892695835e87 /sys-block/di/di-4.41.ebuild
parentapp-benchmarks/filebench: add new maintainers (diff)
downloadgentoo-43358515d3e4cc74fce6de0ef44cc615b60fd6b1.tar.gz
gentoo-43358515d3e4cc74fce6de0ef44cc615b60fd6b1.tar.bz2
gentoo-43358515d3e4cc74fce6de0ef44cc615b60fd6b1.zip
sys-block/di: Bump to version 4.41
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/di/di-4.41.ebuild')
-rw-r--r--sys-block/di/di-4.41.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/di/di-4.41.ebuild b/sys-block/di/di-4.41.ebuild
new file mode 100644
index 000000000000..42ea3cc89ab1
--- /dev/null
+++ b/sys-block/di/di-4.41.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="http://www.gentoo.com/di/"
+SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RESTRICT="test" #405205, #405471
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.33-build.patch
+}
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README
+}