summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-06 11:47:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-06 11:48:05 +0200
commit499172cde2ad57c37c8a098dca1d5a3bb1800ab6 (patch)
treeb8d9b7331dfc6e120e6f28f78987f96e06fe8d2f /sys-block/di/di-4.50.ebuild
parentmedia-gfx/asymptote: bump to 2.70 (diff)
downloadgentoo-499172cde2ad57c37c8a098dca1d5a3bb1800ab6.tar.gz
gentoo-499172cde2ad57c37c8a098dca1d5a3bb1800ab6.tar.bz2
gentoo-499172cde2ad57c37c8a098dca1d5a3bb1800ab6.zip
sys-block/di: Bump to version 4.50
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/di/di-4.50.ebuild')
-rw-r--r--sys-block/di/di-4.50.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-block/di/di-4.50.ebuild b/sys-block/di/di-4.50.ebuild
new file mode 100644
index 000000000000..0b91156a628d
--- /dev/null
+++ b/sys-block/di/di-4.50.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Disk Information Utility"
+HOMEPAGE="https://diskinfo-di.sourceforge.io/"
+SRC_URI="mirror://sourceforge/diskinfo-di/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="nls"
+
+RESTRICT="test" #405205, #405471
+
+BDEPEND="nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.33-build.patch
+)
+
+src_configure() {
+ emake checkbuild
+ emake -C C config.h
+}
+
+src_compile() {
+ emake prefix=/usr CC="$(tc-getCC)" NLS=$(usex nls T F)
+}
+
+src_install() {
+ emake install prefix="${D}/usr"
+ # default symlink is broken
+ dosym di /usr/bin/mi
+ dodoc README.txt
+}