summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-07 15:23:11 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-07 18:05:13 +0100
commit7f7f49543afe39baeaab0427de8dd5cce34e6776 (patch)
tree264c8d02825634fb038e172015182e91c4cd34ea /sys-block/endpoint/endpoint-0.1.0-r1.ebuild
parentmedia-sound/cadence: fixed qa issues (diff)
downloadgentoo-7f7f49543afe39baeaab0427de8dd5cce34e6776.tar.gz
gentoo-7f7f49543afe39baeaab0427de8dd5cce34e6776.tar.bz2
gentoo-7f7f49543afe39baeaab0427de8dd5cce34e6776.zip
sys-block/endpoint: EAPI-7 revbump
Closes: https://bugs.gentoo.org/697192 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block/endpoint/endpoint-0.1.0-r1.ebuild')
-rw-r--r--sys-block/endpoint/endpoint-0.1.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-block/endpoint/endpoint-0.1.0-r1.ebuild b/sys-block/endpoint/endpoint-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..d23f599eff85
--- /dev/null
+++ b/sys-block/endpoint/endpoint-0.1.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Endpoint turns a Linux machine with a firewire card into an SBP-2 device"
+HOMEPAGE="http://oss.oracle.com/projects/endpoint/"
+SRC_URI="http://oss.oracle.com/projects/endpoint/dist/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/libraw1394-0.9
+ >=dev-libs/glib-2:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-errormessages.patch
+)
+
+src_install() {
+ emake -j1 install DESTDIR="${D}"
+ insinto /etc
+ newins docs/sample-endpoint.conf endpoint.conf
+ dodoc README AUTHORS ChangeLog
+}