summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2021-02-19 18:21:22 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-02-19 18:21:22 -0800
commit7bbc54d939b14e626af57c9bf0a483efb75ce640 (patch)
tree711e8296ce938c2125dd3a67d1deb3bf552a2912 /sys-block/libzbc/libzbc-5.9.0.ebuild
parentdev-python/snappy: Stabilize 0.6.0 arm64, #771477 (diff)
downloadgentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.tar.gz
gentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.tar.bz2
gentoo-7bbc54d939b14e626af57c9bf0a483efb75ce640.zip
sys-block/libzbc-5.9.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-block/libzbc/libzbc-5.9.0.ebuild')
-rw-r--r--sys-block/libzbc/libzbc-5.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/libzbc/libzbc-5.9.0.ebuild b/sys-block/libzbc/libzbc-5.9.0.ebuild
new file mode 100644
index 000000000000..41daf6685699
--- /dev/null
+++ b/sys-block/libzbc/libzbc-5.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A library and tools for working with ZBC and ZAC disks"
+HOMEPAGE="https://github.com/hgst/libzbc"
+SRC_URI="https://github.com/hgst/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2 GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND="
+ virtual/pkgconfig
+ >=sys-kernel/linux-headers-4.13
+ gtk? ( x11-libs/gtk+:3 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk gui) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}