summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-10-27 09:33:13 +1300
committerThomas Deutschmann <whissi@gentoo.org>2020-10-26 22:28:24 +0100
commita980b82787f8cb734a96776e7913f0555b6c3ad6 (patch)
tree7bebacadec9587fa5b58ec5900af9002dcb8a772 /sys-block/lsiutil/lsiutil-1.62-r3.ebuild
parentdev-ml/cryptokit: Stabilize 1.11 ppc, #737156 (diff)
downloadgentoo-a980b82787f8cb734a96776e7913f0555b6c3ad6.tar.gz
gentoo-a980b82787f8cb734a96776e7913f0555b6c3ad6.tar.bz2
gentoo-a980b82787f8cb734a96776e7913f0555b6c3ad6.zip
sys-block/lsiutil: EAPI 7
Closes: https://bugs.gentoo.org/712668 Closes: https://bugs.gentoo.org/689820 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-block/lsiutil/lsiutil-1.62-r3.ebuild')
-rw-r--r--sys-block/lsiutil/lsiutil-1.62-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-block/lsiutil/lsiutil-1.62-r3.ebuild b/sys-block/lsiutil/lsiutil-1.62-r3.ebuild
new file mode 100644
index 000000000000..9efcadaec795
--- /dev/null
+++ b/sys-block/lsiutil/lsiutil-1.62-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LSI Logic Fusion MPT Command Line Interface management tool"
+HOMEPAGE="https://www.broadcom.com/"
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/legacy-host-bus-adapters/legacy-host-bus-adapters-common-files/LSIUtil_${PV/./-}.zip"
+
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+RESTRICT="mirror bindist"
+
+BDEPEND="app-arch/unzip"
+QA_PRESTRIPPED="/opt/bin/lsiutil"
+
+S="${WORKDIR}"
+
+src_install() {
+ exeinto /opt/bin
+ use amd64 && newexe Linux/lsiutil.x86_64 lsiutil
+ use ia64 && newexe Linux/lsiutil.ia64 lsiutil
+ use x86 && doexe Linux/lsiutil
+
+ dodoc changes.txt
+}