summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-02-08 16:12:15 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-02-08 16:13:16 -0800
commitf6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0 (patch)
tree53b1eb416f4363fa3190c1649326c43e9065be15 /sys-block/megacli/megacli-8.07.14-r1.ebuild
parentx11-misc/xdotool: bump (diff)
downloadgentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.tar.gz
gentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.tar.bz2
gentoo-f6afcf81e3bb4e02f5960c3737d7f4ccd1674ab0.zip
sys-block/megacli: per bug #563218 and sys-block/lsiutil, upstream does not fetch-restrict anymore.
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-block/megacli/megacli-8.07.14-r1.ebuild')
-rw-r--r--sys-block/megacli/megacli-8.07.14-r1.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/sys-block/megacli/megacli-8.07.14-r1.ebuild b/sys-block/megacli/megacli-8.07.14-r1.ebuild
new file mode 100644
index 000000000000..ca44b0c178ce
--- /dev/null
+++ b/sys-block/megacli/megacli-8.07.14-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit rpm
+MY_PV="${PV//./-}"
+MY_P=${MY_PV}_MegaCLI
+
+DESCRIPTION="LSI Logic MegaRAID Command Line Interface management tool"
+# Avagotech now owns LSI
+HOMEPAGE="http://www.www.avagotech.com/"
+SRC_URI="http://docs.avagotech.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${MY_P}.zip"
+
+LICENSE="LSI"
+SLOT="0"
+# This package can never enter stable, it can't be mirrored and upstream
+# can remove the distfiles from their mirror anytime.
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip
+ app-admin/chrpath"
+RDEPEND=""
+
+S=${WORKDIR}
+
+# Previous releases from LSI directly required a click-through EULA; but the
+# upstream website no longer requires this consistently: most old files have
+# two or more download pages, and while one of the pages has a generic
+# click-through download form, the file-specific download page only requires
+# click-through on some items. See also sys-block/lsiutil
+RESTRICT="mirror bindist"
+QA_PREBUILT="/opt/${PN}/${PN}
+ /opt/${PN}/lib/*"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rpm_unpack ./Linux/MegaCli-${PV}-1.noarch.rpm
+}
+
+src_install() {
+ newdoc "${PV}_MegaCLI.txt" RELEASE.txt
+
+ exeinto /opt/megacli
+ libsysfs=libstorelibir-2.so.14.07-0
+ case ${ARCH} in
+ amd64) MegaCli=MegaCli64;;
+ x86) MegaCli=MegaCli;;
+ *) die "invalid ARCH";;
+ esac
+ newexe opt/MegaRAID/MegaCli/${MegaCli} ${PN}
+
+ exeinto /opt/${PN}/lib
+ doexe opt/MegaRAID/MegaCli/${libsysfs}
+
+ into /opt
+ newbin "${FILESDIR}"/${PN}-wrapper ${PN}
+ dosym ${PN} /opt/bin/MegaCli
+
+ # Remove DT_RPATH
+ chrpath -d "${D}"/opt/${PN}/${PN}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "See /usr/share/doc/${PF}/RELEASE.txt for a list of supported controllers"
+ einfo "(contains LSI model names only, not those sold by 3rd parties"
+ einfo "under custom names like Dell PERC etc)."
+ einfo
+ einfo "As there's no dedicated manual, you might want to have"
+ einfo "a look at the following cheat sheet (originally written"
+ einfo "for Dell PowerEdge Expandable RAID Controllers):"
+ einfo "http://tools.rapidsoft.de/perc/perc-cheat-sheet.html"
+ einfo
+ einfo "For more information about working with Dell PERCs see:"
+ einfo "http://tools.rapidsoft.de/perc/"
+ einfo
+}