summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-block/sas3ircu/sas3ircu-5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-block/sas3ircu/sas3ircu-5.ebuild')
-rw-r--r--sys-block/sas3ircu/sas3ircu-5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-block/sas3ircu/sas3ircu-5.ebuild b/sys-block/sas3ircu/sas3ircu-5.ebuild
new file mode 100644
index 000000000000..cd810bc58d8c
--- /dev/null
+++ b/sys-block/sas3ircu/sas3ircu-5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit mount-boot
+
+DESCRIPTION="LSI MPT-SAS3 controller management tool"
+HOMEPAGE="http://www.lsi.com/support/Pages/download-results.aspx?component=Storage+Component&productfamily=Host+Bus+Adapters&productcode=0&assettype=Miscellaneous&productname=&keyword=SAS3IRCU"
+LICENSE="LSI"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~ppc64 ~amd64-fbsd ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="efi doc"
+RESTRICT="strip fetch mirror"
+DEPEND=""
+RDEPEND=""
+QA_PREBUILT="opt/lsi/sas3ircu boot/efi/sas3ircu.efi"
+
+MY_PN=SAS3IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC=SAS3IRCU_UG.pdf
+
+SRC_URI="
+http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/Host%20Bus%20Adapters%20Common%20Files/SAS_SATA_12G_P${PV}/${DISTFILE_BIN}
+doc? ( http://www.lsi.com/downloads/Public/Host%20Bus%20Adapters/${DISTFILE_DOC} )
+"
+
+LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ elog "LSI has a mandatory click-through license on thier binaries."
+ elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Mangement Software section."
+ elog "After downloading, move ${MY_P} into $DISTDIR"
+ if use doc; then
+ elog "Please also download 'SAS-3 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
+ elog "and also place it into $DISTDIR"
+ fi
+}
+
+supportedcards() {
+ elog "This binary supports should support ALL cards, including, but not"
+ elog "limited to the following series:"
+ elog ""
+ elog "LSI SAS 3004"
+ elog "LSI SAS 3008"
+}
+
+src_unpack() {
+ unpack ${DISTFILE_BIN}
+}
+
+src_install() {
+ exeinto /opt/lsi/
+ use amd64 || use x86 && doexe sas3ircu_linux_x86_rel/sas3ircu
+ use ppc64 && doexe sas3ircu_linux_x86_rel/sas3ircu
+ use amd64-fbsd && doexe sas3ircu_freebsd_amd64_rel/sas3ircu
+ use x86-fbsd && doexe sas3ircu_freebsd_i386_rel/sas3ircu
+ use x64-solaris || use x86-solaris && doexe sas3ircu_solaris_x86_rel/sas3ircu
+ use sparc-solaris && doexe sas3ircu_solaris_sparc_rel/sas3ircu
+ if use efi; then
+ exeinto /boot/efi/
+ doexe sas3ircu_udk_uefi__x64_rel/sas3ircu.efi
+ fi
+ dodoc IRCU_MPT_GEN3_Phase5.0-06.00.00.00.pdf
+ dodoc README_SAS3IRCU_P${PV}.txt
+ use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
+}