summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-27 20:31:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-27 22:34:34 -0400
commit4153ee687b291e4ce63a3826a85ec044b736a492 (patch)
tree1f3a2349bca51716d89a52f7536f70a25a2d593d /sys-block/scsiping
parentsys-block/scsiping: EAPI7->8, respect CC, remove dead HOMEPAGE (diff)
downloadgentoo-4153ee687b291e4ce63a3826a85ec044b736a492.tar.gz
gentoo-4153ee687b291e4ce63a3826a85ec044b736a492.tar.bz2
gentoo-4153ee687b291e4ce63a3826a85ec044b736a492.zip
sys-block/scsiping: fix build with clang16
Previous commit let this respect CC, so maybe clang will be used now... Closes: https://bugs.gentoo.org/870445 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-block/scsiping')
-rw-r--r--sys-block/scsiping/files/scsiping-0.0.1-clang16.patch8
-rw-r--r--sys-block/scsiping/scsiping-0.0.1-r1.ebuild4
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-block/scsiping/files/scsiping-0.0.1-clang16.patch b/sys-block/scsiping/files/scsiping-0.0.1-clang16.patch
new file mode 100644
index 000000000000..9e57d9cc4aa0
--- /dev/null
+++ b/sys-block/scsiping/files/scsiping-0.0.1-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/870445
+--- a/main.c
++++ b/main.c
+@@ -2,2 +2,4 @@
+ #include <stdio.h>
++#include <stdlib.h>
++#include <sys/ioctl.h>
+ #include <string.h>
diff --git a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
index 745fd177ef62..d3777024a378 100644
--- a/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
+++ b/sys-block/scsiping/scsiping-0.0.1-r1.ebuild
@@ -13,6 +13,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
src_prepare() {
default