summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-01-04 02:42:17 +0100
committerThomas Deutschmann <whissi@gentoo.org>2017-01-04 02:42:17 +0100
commit8694e70b7001b2296d4aec13d9a861028d8daf48 (patch)
tree988e90f6730fca8520804d71562e81bbf188bade /sys-block/storcli/storcli-1.20.15.ebuild
parentnet-libs/zeromq: Bump to v4.2.1 (diff)
downloadgentoo-8694e70b7001b2296d4aec13d9a861028d8daf48.tar.gz
gentoo-8694e70b7001b2296d4aec13d9a861028d8daf48.tar.bz2
gentoo-8694e70b7001b2296d4aec13d9a861028d8daf48.zip
sys-block/storcli: Bump to v1.20.15
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sys-block/storcli/storcli-1.20.15.ebuild')
-rw-r--r--sys-block/storcli/storcli-1.20.15.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-block/storcli/storcli-1.20.15.ebuild b/sys-block/storcli/storcli-1.20.15.ebuild
new file mode 100644
index 000000000000..d179a8f44b2f
--- /dev/null
+++ b/sys-block/storcli/storcli-1.20.15.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit pax-utils
+
+DESCRIPTION="MegaRAID StorCLI (successor of the MegaCLI)"
+HOMEPAGE="http://www.avagotech.com/support/download-search?dnd-keyword=storcli"
+# For new versions check http://www.avagotech.com/cs/Satellite?pagename=AVG2/Utilities/searchResultsJson&page=1&q=storcli&endDate=null&searchType=type-AVG_Document_C~Downloads&isEntitled=null&dynamic-search-relevance=Newest
+SRC_URI="https://docs.broadcom.com/docs-and-downloads/raid-controllers/raid-controllers-common-files/${PV}_StorCLI.zip -> ${P}.zip"
+
+LICENSE="Avago LSI BSD"
+SLOT="0/6.12"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+DOCS=( readme.txt license.txt )
+
+MY_STORCLI_BASEDIR="/opt/lsi/storcli"
+
+QA_PRESTRIPPED="${MY_STORCLI_BASEDIR:1}/storcli"
+
+src_unpack() {
+ unpack ${A}
+
+ mv storcli_All_OS/storcli_All_OS/Ubuntu/storcli_*.deb "${WORKDIR}" || die "Failed to move storclli_*.deb"
+
+ # Unpack Ubuntu package which will be our $S content
+ unpack "${WORKDIR}"/storcli_*.deb
+ rm -f storcli_*.deb || die "Failed to cleanup storcli_*.deb package"
+ unpack "${WORKDIR}"/data.tar.gz
+
+ mkdir "${S}" || die "Failed to create '${S}'"
+}
+
+src_prepare() {
+ default
+
+ # Create clean $S
+ mv "${WORKDIR}"/*CLI.txt "${S}"/readme.txt || die "Failed to move *CLI.txt to readme.txt"
+ mv "${WORKDIR}"/storcli_All_OS/storcli_All_OS/Linux/license.txt "${S}"/license.txt || die "Failed to move Linux/license.txt"
+ rm -rf "${WORKDIR}"/storcli_all* || die "Failed to cleanup storcli_all* dirs/files"
+ mv "${WORKDIR}"/opt/Mega*/storcli/* "${S}" || die "Failed to move storcli_.deb content to '${S}'"
+ rm -rf "${WORKDIR}"/{opt,control.tar.gz,data.tar.gz,debian-binary} || die "Failed to cleanup no longer needed files"
+}
+
+src_install() {
+ exeinto "${MY_STORCLI_BASEDIR}"
+
+ if use x86; then
+ doexe storcli
+ elif use amd64; then
+ newexe storcli64 storcli
+ fi
+
+ dosym "${MY_STORCLI_BASEDIR}"/storcli /usr/sbin/storcli
+
+ dodoc "${DOCS[@]}"
+
+ pax-mark m "${D%/}${MY_STORCLI_BASEDIR}"/storcli
+}